summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 22:30:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:37 -0500
commit10cf8402dd054a57bb6b377cd0abc45e9f1cb89f (patch)
tree134a2e75b40a80cef1cc884a1584e40ddeea574b /dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild
parentdev-python/pyjwt: 1.7.1 bump (diff)
downloadgentoo-10cf8402dd054a57bb6b377cd0abc45e9f1cb89f.tar.gz
gentoo-10cf8402dd054a57bb6b377cd0abc45e9f1cb89f.tar.bz2
gentoo-10cf8402dd054a57bb6b377cd0abc45e9f1cb89f.zip
dev-python/dogpile-cache: 0.7.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild')
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild
new file mode 100644
index 000000000000..27d7bd1ec53e
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}] )"
+
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ "${EPYTHON}" ./setup.py test || die "test failed under ${EPYTHON}"
+}