summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 16:19:36 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 17:02:30 +0200
commit659867b70765776d0ba2b87e7d1ba224d72efe42 (patch)
treed3134cce3d1c50d271d081901c68ad351212b589 /dev-python/dictdiffer/dictdiffer-0.8.1.ebuild
parentdev-python/stdio-mgr: import from ::guru (diff)
downloadgentoo-659867b70765776d0ba2b87e7d1ba224d72efe42.tar.gz
gentoo-659867b70765776d0ba2b87e7d1ba224d72efe42.tar.bz2
gentoo-659867b70765776d0ba2b87e7d1ba224d72efe42.zip
dev-python/dictdiffer: add new dep of sphobjinv
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/dictdiffer/dictdiffer-0.8.1.ebuild')
-rw-r--r--dev-python/dictdiffer/dictdiffer-0.8.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/dictdiffer/dictdiffer-0.8.1.ebuild b/dev-python/dictdiffer/dictdiffer-0.8.1.ebuild
new file mode 100644
index 000000000000..fb46f2e49d04
--- /dev/null
+++ b/dev-python/dictdiffer/dictdiffer-0.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Dictdiffer is a library that helps you to diff and patch dictionaries"
+HOMEPAGE="
+ https://github.com/inveniosoftware/dictdiffer/
+ https://pypi.org/project/dictdiffer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# Requires self to be already installed
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # remove dep on pytest-runner
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ # remove dep on pytest-pep8 and pytest-cov
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}