summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-09 14:48:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-09 15:08:13 +0200
commit3526ec7c90064d85e83f378c6cb00d96fd8c9170 (patch)
tree7f6005e39690343e5594e4cbb37337fbb911c93d /dev-python/deprecation
parentmedia-libs/libprojectm: keyworded 3.1.7 for sparc, bug #732332 (diff)
downloadgentoo-3526ec7c90064d85e83f378c6cb00d96fd8c9170.tar.gz
gentoo-3526ec7c90064d85e83f378c6cb00d96fd8c9170.tar.bz2
gentoo-3526ec7c90064d85e83f378c6cb00d96fd8c9170.zip
dev-python/deprecation: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecation')
-rw-r--r--dev-python/deprecation/deprecation-2.0.7.ebuild24
1 files changed, 3 insertions, 21 deletions
diff --git a/dev-python/deprecation/deprecation-2.0.7.ebuild b/dev-python/deprecation/deprecation-2.0.7.ebuild
index 112502583e07..e60bd8935988 100644
--- a/dev-python/deprecation/deprecation-2.0.7.ebuild
+++ b/dev-python/deprecation/deprecation-2.0.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit distutils-r1
@@ -14,31 +14,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/unittest2[${PYTHON_USEDEP}]
- ${RDEPEND}
)
"
-python_prepare_all() {
- sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
-}
+distutils_enable_sphinx docs
+distutils_enable_tests unittest