summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-03 10:44:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-03 10:46:14 +0200
commit9aa4ab27b489e19b1eadfd36f5ff538e3c9192a8 (patch)
treee6624bb480c33b272c53d3b9356bcdcec0357405 /dev-python/denonavr
parentdev-python/ftfy: New package, v6.2.0 (diff)
downloadgentoo-9aa4ab27b489e19b1eadfd36f5ff538e3c9192a8.tar.gz
gentoo-9aa4ab27b489e19b1eadfd36f5ff538e3c9192a8.tar.bz2
gentoo-9aa4ab27b489e19b1eadfd36f5ff538e3c9192a8.zip
dev-python/denonavr: Bump to 0.11.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.11.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index dbb018a9a481..e4b6d54609d2 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1 +1,2 @@
DIST denonavr-0.11.4.tar.gz 179759 BLAKE2B c75b5679c614f3776afd8a24befb49ca5c2528cb6cd6a573ea221cc66e7b9ec9819770b646c52c0aed126b35733aab09a9eb7c5f673a8e3208507d0afda36117 SHA512 7bdae172034122cc55571dd83888091987c973e29fd0f881428d09c093510c99f4c6eceaab0868d024a2e6acca36eaa941d62332849e7dc2547a88111d8dc55a
+DIST denonavr-0.11.6.tar.gz 181608 BLAKE2B 6078aa16ce879417d21d1f9260bc18e86de9c33054b46592a6af821a349973e6fe69c64a23a23b2b2278edf12180fe37cb218b83c0c0abc536928124fa5dad9a SHA512 538127e30fe71f14643acada521bbd9090999464a4ead1b95805d759d23efd55a87a8a2daf26cd8eebf6c0396850430cac2ef7328ee79921df0862c2713e5208
diff --git a/dev-python/denonavr/denonavr-0.11.6.ebuild b/dev-python/denonavr/denonavr-0.11.6.ebuild
new file mode 100644
index 000000000000..ed574fb2699c
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.11.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/ftfy-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest