summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-02-26 21:23:06 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-02-26 21:23:45 +0700
commitf369e978f691eab9f4ca842a414449b1211ce857 (patch)
treea9e0c41c4408195eb5ea089e07e4288b7678b2ce /dev-python/curtsies
parentkde-plasma: Add KDE Plasma 5.15.2 (diff)
downloadgentoo-f369e978f691eab9f4ca842a414449b1211ce857.tar.gz
gentoo-f369e978f691eab9f4ca842a414449b1211ce857.tar.bz2
gentoo-f369e978f691eab9f4ca842a414449b1211ce857.zip
dev-python/curtsies: depend on dev-python/typing correctly
Bug: https://bugs.gentoo.org/show_bug.cgi?id=678742 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/curtsies')
-rw-r--r--dev-python/curtsies/curtsies-0.3.0-r1.ebuild38
-rw-r--r--dev-python/curtsies/files/curtsies-typing.patch9
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.3.0-r1.ebuild b/dev-python/curtsies/curtsies-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..b12c3e7ffddb
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.3.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+ python_targets_python2_7? ( dev-python/typing[python_targets_python2_7] )
+ python_targets_python3_4? ( dev-python/typing[python_targets_python3_4] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-typing.patch )
+
+python_test() {
+ nosetests --verbose tests || die
+}
diff --git a/dev-python/curtsies/files/curtsies-typing.patch b/dev-python/curtsies/files/curtsies-typing.patch
new file mode 100644
index 000000000000..28ab09f89fe9
--- /dev/null
+++ b/dev-python/curtsies/files/curtsies-typing.patch
@@ -0,0 +1,9 @@
+diff -r -U2 curtsies-0.3.0.orig/setup.py curtsies-0.3.0/setup.py
+--- curtsies-0.3.0.orig/setup.py 2018-02-14 05:54:06.000000000 +0700
++++ curtsies-0.3.0/setup.py 2019-02-26 17:10:07.076471372 +0700
+@@ -42,5 +42,4 @@
+ 'blessings>=1.5',
+ 'wcwidth>=0.1.4',
+- 'typing',
+ ],
+ tests_require = [