summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-26 12:15:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-26 12:30:47 +0200
commit1ef519727896cfcec3eeab918a4a0a56495b0843 (patch)
tree08571225f0ebc7cb4eb043ec9ec839f3b09db5d8 /dev-python/css-parser
parentdev-util/pkgdev: Stabilize 0.2.1-r3 ALLARCHES, #873043 (diff)
downloadgentoo-1ef519727896cfcec3eeab918a4a0a56495b0843.tar.gz
gentoo-1ef519727896cfcec3eeab918a4a0a56495b0843.tar.bz2
gentoo-1ef519727896cfcec3eeab918a4a0a56495b0843.zip
dev-python/css-parser: Bump to 1.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/css-parser')
-rw-r--r--dev-python/css-parser/Manifest1
-rw-r--r--dev-python/css-parser/css-parser-1.0.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/css-parser/Manifest b/dev-python/css-parser/Manifest
index 326256e92810..c5f1369f7569 100644
--- a/dev-python/css-parser/Manifest
+++ b/dev-python/css-parser/Manifest
@@ -1 +1,2 @@
DIST css-parser-1.0.7.tar.gz 348843 BLAKE2B 72fd2a0555eea2b912d3088b1d38a4bf082862a47a414c4c00718ad1b31299a3df3b2e9dcf4f22c3195520c28f5652aaf4103a9a999ceb3ea6b8c785f50bb40e SHA512 51e4ca836b18f963d798a14762bed78cbd3034598cc828dfe81b3f7d921a5bfe52374b0dc6160e1c01e40a8c8147a10664b9f7edeee867ca1086e6a4a96ff162
+DIST css-parser-1.0.8.tar.gz 349363 BLAKE2B 2e67d74422cf87e1c593793f6acc9089a745d020cba18c63c70bc2099f53aad95bd5de1def49a3f5ab7cbff7f91efb3a60b3d2d9f1efa55244d99770f0d7baec SHA512 1b22665a172b8a29e277217f39bac1512867dbd5acdfe37ddf078eab71452467adc3dcdac68e424df32cc204f3e55da45d31663f8e7aa143c0243818df32487a
diff --git a/dev-python/css-parser/css-parser-1.0.8.ebuild b/dev-python/css-parser/css-parser-1.0.8.ebuild
new file mode 100644
index 000000000000..32a11043881f
--- /dev/null
+++ b/dev-python/css-parser/css-parser-1.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library (fork of cssutils)"
+HOMEPAGE="
+ https://github.com/ebook-utils/css-parser/
+ https://pypi.org/project/css-parser/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest