summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-18 18:19:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-18 20:13:45 +0200
commit2dd64bbd0a198a6ec17db8a3b7e6c5cad3e93063 (patch)
tree4dbb99f467e119c568db0e40acacc5dc71fc7c04 /dev-python/coverage
parentdev-libs/libclc: Add 18.1.4 (diff)
downloadgentoo-2dd64bbd0a198a6ec17db8a3b7e6c5cad3e93063.tar.gz
gentoo-2dd64bbd0a198a6ec17db8a3b7e6c5cad3e93063.tar.bz2
gentoo-2dd64bbd0a198a6ec17db8a3b7e6c5cad3e93063.zip
dev-python/coverage: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-7.4.3.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 080ee9646050..606347d6e845 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,2 +1 @@
-DIST coverage-7.4.3.tar.gz 783214 BLAKE2B d9c3bba00ffd85d3ed260613880b7c8214be11092d539c011894a9d0b9b57f462b20ca38622c6c8aafa575220e34e9c0affa512cffa372ea4d421b89296193b8 SHA512 10c64eddb5d95023cb9d5c480b898389a041ab8d354a7cb48f1ed39f9bc958cc4be21ee04be620e9c74d102fd81f215f6f949a3dd8817e39300a1de4d4913fa5
DIST coverage-7.4.4.tar.gz 783727 BLAKE2B e7d7af92ddcb3d7b5857cc83d8e14bb16ea2bde720eba63b082d35358934047ef7285ac70a6cd8fcb4720a9ddea5c22cf4cb14404ac2800794c49650ff5a1dd4 SHA512 26d4715ce69556ca12d1b65db5f21807c08733810b4398750280184812ebfb698e7b424b9e30f55e7524323861a22d4581db0524e9e285ca858132359fd24d28
diff --git a/dev-python/coverage/coverage-7.4.3.ebuild b/dev-python/coverage/coverage-7.4.3.ebuild
deleted file mode 100644
index 7e8f13a6c388..000000000000
--- a/dev-python/coverage/coverage-7.4.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="
- https://coverage.readthedocs.io/en/latest/
- https://github.com/nedbat/coveragepy/
- https://pypi.org/project/coverage/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{9..10})
-"
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/addopts/s:-q -n auto::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-test_tracer() {
- local -x COVERAGE_CORE=${1}
- einfo " Testing with the ${COVERAGE_CORE} core ..."
- epytest -p flaky -p hypothesis -p xdist tests
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO: fails because of additional "Terminated" print on SIGTERM
- tests/test_concurrency.py::SigtermTest::test_sigterm_threading_saves_data
- # broken because of pytest plugins explicity loaded
- tests/test_debug.py::ShortStackTest::test_short_stack{,_skip}
- # these expect specific availability of C extension matching
- # COVERAGE_CORE (which breaks testing pytracer on CPython)
- tests/test_cmdline.py::CmdLineStdoutTest::test_version
- tests/test_debug.py::DebugTraceTest::test_debug_sys_ctracer
- )
- local EPYTEST_IGNORE=(
- # pip these days insists on fetching build deps from Internet
- tests/test_venv.py
- )
-
- "${EPYTHON}" igor.py zip_mods || die
-
- local -x COVERAGE_TESTING=True
- # TODO: figure out why they can't be imported inside test env
- local -x COVERAGE_NO_CONTRACTS=1
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
-
- local prev_opt=$(shopt -p nullglob)
- shopt -s nullglob
- local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
- ${prev_opt}
-
- if [[ -n ${c_ext} ]]; then
- cp "${c_ext}" coverage/ || die
- test_tracer ctrace
- fi
-
- test_tracer pytrace
-
- case ${EPYTHON} in
- python3.1[01]|pypy3)
- ;;
- *)
- # available since Python 3.12
- test_tracer sysmon
- ;;
- esac
-
- if [[ -n ${c_ext} ]]; then
- rm coverage/*.so || die
- fi
-}