summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-15 23:18:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-15 23:18:36 +0300
commit0db626ddce2afb64d503e3e589d1438fd21f5245 (patch)
tree4d1ec963dced1794b04994191e99651c881cb4bd /dev-python/cfn-lint
parentdev-python/idna: add 3.4 (diff)
downloadgentoo-0db626ddce2afb64d503e3e589d1438fd21f5245.tar.gz
gentoo-0db626ddce2afb64d503e3e589d1438fd21f5245.tar.bz2
gentoo-0db626ddce2afb64d503e3e589d1438fd21f5245.zip
dev-python/cfn-lint: add 0.65.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.65.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index f5d923e64fbd..370c6ee0847f 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -4,3 +4,4 @@ DIST cfn-lint-0.63.0.gh.tar.gz 9613588 BLAKE2B 96f36310b9201e39a03fb9ca4e102feed
DIST cfn-lint-0.63.2.gh.tar.gz 9672817 BLAKE2B dcd445c2372bf044bc4eab4b33056d2113914cdeeb1a2b376643cc4bbb3d92dcfdaaf2e6aa5f0d0473be00b42ecea0eda2a5ae3fa493d4e648be12db81b9d9e7 SHA512 d9bff0c43f7c2b710536fb7212e3d78d3827d7838ef8246767625c3de1a2ee0e5056df42b6b94e0efd7e7b2933d477a9962e0e3d53a78a3cca774fd52706a330
DIST cfn-lint-0.64.0.gh.tar.gz 9792738 BLAKE2B f74d8131d46c5fc1cf78fcf7e3a6620d1c19288437c3eda896fe357518aa91056826e7c80c860c636a7394a021852b4ef93451d0bcf03efb1b7b1da41f0b1652 SHA512 4e4cc098f0f7024456278e5994b0508408cb70230934ced084c67ddecae2070c1686430b367b0c812274d40201256a9f8ca0d30c208ee00c2435dcad09419d80
DIST cfn-lint-0.64.1.gh.tar.gz 9792758 BLAKE2B 95bc86fa41c17498575abfd4eb7e16d9e8a8dfc36d4304aa216890773e52d1e43f4deb178f2bd69c8edc445a417ca37ef53069ac9d398ccf27e3b9a6d90ee8c9 SHA512 edd7296e74db943c6ae818c2ae8f5220c4d8834eb7858c474e38f7852c1a7839b89ba949c105a3d2044f4b952e56fdc9e7a08493ed74e06b29ec9c0ea0b48a6a
+DIST cfn-lint-0.65.0.gh.tar.gz 9807118 BLAKE2B abafc4fac788ba0af80359997b92cd60089472dee51952fc3029485a87be8e8fb9deb1599610471216ee8da103f7198808f9122727182005140c527672a921f8 SHA512 68eeb18914fb92cdacea9f80d4564937eba92b645f62a3fc22e874001554837ac3107741d4134cc8b1d880eaca38a560a92631c6ae3dfb2c412ad6fcb3f91cab
diff --git a/dev-python/cfn-lint/cfn-lint-0.65.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.65.0.ebuild
new file mode 100644
index 000000000000..57fd1d8c6029
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.65.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.47.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}