summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-12 12:37:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-12 12:38:20 +0100
commite4a7bcdb8a18f2985f04054400ace1b6a9ec9aa4 (patch)
treeeb009212729364add3c3a0fc44a13caa07d27f7b /dev-python/braintree
parentdev-python/build: Restore deselect for toml fallback test (diff)
downloadgentoo-e4a7bcdb8a18f2985f04054400ace1b6a9ec9aa4.tar.gz
gentoo-e4a7bcdb8a18f2985f04054400ace1b6a9ec9aa4.tar.bz2
gentoo-e4a7bcdb8a18f2985f04054400ace1b6a9ec9aa4.zip
dev-python/braintree: Bump to 4.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/braintree')
-rw-r--r--dev-python/braintree/Manifest1
-rw-r--r--dev-python/braintree/braintree-4.18.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/braintree/Manifest b/dev-python/braintree/Manifest
index 4a833412b9c8..107e1cd4702d 100644
--- a/dev-python/braintree/Manifest
+++ b/dev-python/braintree/Manifest
@@ -1 +1,2 @@
DIST braintree_python-4.17.1.gh.tar.gz 213195 BLAKE2B 2ca1176d3fcdf670ced8bc9de4c2c7140823ec4e1f34acc8235003dd57d16b8e5b411756e1c52da68fc5dcc6009333317952ab246d51c3da71b0a1bed81ea8d1 SHA512 a6835f50451d6e914be5c691920f07fdf804c98580625bfc6984b83c5bf9acffe7b8005d6ffc201e8c0826b65ba4549a5159fde9988da57d08626bb226a35feb
+DIST braintree_python-4.18.0.gh.tar.gz 216422 BLAKE2B 30ed072c3f6c6ae3cc9661fe5a1f49327ad2fd17261590a61aaae543966a40c9018a1c3b789e1ba3f387a8d93cff35c8b7ffd589e76ffefc572b7dc9fcd84951 SHA512 2abdec5e16386bed5e9c6d1d085ec604050907a57bf9dbe65c6c3d05b2bdf8f00929e11729b50a4774ab2bdd61a1a8d4a73f6c23368b663cc5757562b8ce1e4f
diff --git a/dev-python/braintree/braintree-4.18.0.ebuild b/dev-python/braintree/braintree-4.18.0.ebuild
new file mode 100644
index 000000000000..a74aca49c2a8
--- /dev/null
+++ b/dev-python/braintree/braintree-4.18.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=braintree_python-${PV}
+DESCRIPTION="Braintree Python Library"
+HOMEPAGE="
+ https://developer.paypal.com/braintree/docs/reference/overview/
+ https://github.com/braintree/braintree_python/
+ https://pypi.org/project/braintree/
+"
+SRC_URI="
+ https://github.com/braintree/braintree_python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-0.11.1[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.md )
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/unit
+}