summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-13 07:06:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-13 07:30:05 +0200
commit4735d5108380f6f8a3e634e7ab198a14d96732c9 (patch)
tree9f748e56b1e4a90a5ba5e2b8f165e4052d7e46c9 /dev-python/botocore
parentdev-ruby/redcloth: enable ruby31 (diff)
downloadgentoo-4735d5108380f6f8a3e634e7ab198a14d96732c9.tar.gz
gentoo-4735d5108380f6f8a3e634e7ab198a14d96732c9.tar.bz2
gentoo-4735d5108380f6f8a3e634e7ab198a14d96732c9.zip
dev-python/botocore: Bump to 1.24.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.24.39.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 86eaf22a9634..1b4f1d23bb5e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.24.35.tar.gz 8891601 BLAKE2B b6a56efa73a3f76f51764c4c649d38f2e59
DIST botocore-1.24.36.tar.gz 8899058 BLAKE2B c11df5acef305116433aeb4c4b999b8bdeba278506ac066bae3572f578cd2877827cc8a45d74f57fd10c5e87fdd46f39b951ec4d5bd15f0c484194640813080a SHA512 49256c288b74126595521eabcab750a58a05d07ecf5243ce0626961963326099c3fa3cb571664fb72c0f835624bd79e55e4940c9fc4b03b2b1dc7fd7d3a71213
DIST botocore-1.24.37.tar.gz 8898823 BLAKE2B 5e5495ba399e910479c0172eb4c572a5c0371db720906586c88dc59d8bfc58a50699b05125e1e554a8571b64654604447be1e1a4bfdc2b992272101060638908 SHA512 412a656e879b09bf9f82d02e291e988499106dce1f589b1048adf2145774a5dd9a9ca5f18d2b6eaedd895e384cbf1836c7b6bdc0867a83c7b863bddea77727f4
DIST botocore-1.24.38.tar.gz 8900705 BLAKE2B 1f1504856d5908df7d8af9f92847d1d7ac9d8ce0258a63bcea4b593aaae4d87e71da45becadb5873eab53ceea6916e4c6a4931efd797b0474e7bfe4f0b60eb46 SHA512 1cf7cf2acc7773ab9f5c4d01eca24191f6d27e3eddd98abd33348bf171bcaa2708e8c9a03ceb2676060a1f906d66e6982fe3bce3b78ed878abc30434812327c0
+DIST botocore-1.24.39.tar.gz 8901325 BLAKE2B ffdafe7b34c7114de12044d14dd9ba58f01b21455f51a527da55450840f7f74cfaee56babb105b18634b06293ef91427534ea08b47d223285046bd718cc6cc7a SHA512 13c24f4e305bc16441682f483b0478730f5487388d73e14fc3750e22fd3c4c1c958146264721f365b00d1cddd4222e7c0b5d0be26df171ba4e95091327a340c8
diff --git a/dev-python/botocore/botocore-1.24.39.ebuild b/dev-python/botocore/botocore-1.24.39.ebuild
new file mode 100644
index 000000000000..3bf7c7cfb689
--- /dev/null
+++ b/dev-python/botocore/botocore-1.24.39.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}