summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-10 22:35:18 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-10 23:34:54 +0100
commitde8bb8f75a5e06034bb111fbb3d6613abbf2772e (patch)
tree3344227021a4c7a7c6f2bce78a25badedafae58a /dev-python/boto3
parentdev-python/botocore: Bump to 1.23.3 (diff)
downloadgentoo-de8bb8f75a5e06034bb111fbb3d6613abbf2772e.tar.gz
gentoo-de8bb8f75a5e06034bb111fbb3d6613abbf2772e.tar.bz2
gentoo-de8bb8f75a5e06034bb111fbb3d6613abbf2772e.zip
dev-python/boto3: Bump to 1.20.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 23aa75705e0c..5ace757ace12 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.19.12.tar.gz 436654 BLAKE2B f92e756bc9f98105e3126e41cf0d6fab948bbd7
DIST boto3-1.19.5.tar.gz 433567 BLAKE2B 52c12a4dd18d6f02326f8002b345cc5df224455fc862daa700326ae1df258979211d2753f01e1a106f237de393e483dc8926bb4ef0e08bafa575f20811dccd55 SHA512 fad05102f0c3e7e30a3342009f6b3ae28f52758f17a0c22b4da9a03dd10d7f9149ea2ec0119f55ec7280824bd8173653271821e82fcd54ef9fb9161b2d62df70
DIST boto3-1.20.1.tar.gz 437338 BLAKE2B b2d952263919404518ada651777fd8cbe501b46fe060c4e4c657e2a01801e8f4b0285864cef880cc7ffeb83a84709f1bc91de26d70378a7ab01e681cc8098857 SHA512 0536a90cefbe739941d1eb5e2cb667de144648a8ba4329b49475fc15855c495fdbb0bf73d0c5de57adfb58f86e01e19ff4ce876eabf185a1f5a93499dafa6d49
DIST boto3-1.20.2.tar.gz 437582 BLAKE2B 7fed58f44e7a6eb4f5aa3f8cf4d1f6e67d818debe55d2ea609f2b1419aafa0f2d9cd15aba48f7d238943bbe5d4b3f5285de731f36df3b8d3276fbd1d411f7374 SHA512 25c5b4f8cc154a408d2d07a88af9e6cad6c1e0ec3544ceb7d8191d8204e5fe45dbfc27796f0b3c2d2a15d86d3f586c53a104575f8ed1eb0ed8a3772723d66e20
+DIST boto3-1.20.3.tar.gz 437920 BLAKE2B e4d6a0ca39bef3212a8eeaccfb79f1a299b7c39794a5ca63dddb0110f47ecf8066f2755bd7a5e016b011b31c2ab6d01f0e2096dde318c1919aba870e9cf0a248 SHA512 b04b46e75482ce8e52295be5c78397acedcb3558716199fcf3a66488f5b0ffb4a6c41818733f0a706d2f2da8f05adcb5a083420ceac490ee36d965246a5fb490
diff --git a/dev-python/boto3/boto3-1.20.3.ebuild b/dev-python/boto3/boto3-1.20.3.ebuild
new file mode 100644
index 000000000000..a4f6b1d0f3c2
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}