summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-03 05:54:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-03 05:54:17 +0200
commit63ed1e5e6123d27af0a524026b7a659d5f53fcd5 (patch)
treebd201d0a2c412f342db8d72d824f76e11b4c65a6 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.153 (diff)
downloadgentoo-63ed1e5e6123d27af0a524026b7a659d5f53fcd5.tar.gz
gentoo-63ed1e5e6123d27af0a524026b7a659d5f53fcd5.tar.bz2
gentoo-63ed1e5e6123d27af0a524026b7a659d5f53fcd5.zip
dev-python/boto3: Bump to 1.34.153
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.153.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 563dabb02d05..550e75a9f08c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.34.149.gh.tar.gz 845064 BLAKE2B 25e77483b8ac8a52e7f5586794839dcab69
DIST boto3-1.34.150.gh.tar.gz 845173 BLAKE2B ad4d63056452b1743b91716fef05f7858ecaff10c4dfc7c10b9ff3bd1b6e7e2a641bbacddbd9ff48ad5536f24692a3423a7b34d174fb9c41961130853b93988c SHA512 87e4f7c6853a4f981f1920e532a8118a40dbcfd5798459fb095f1c5f3bedde9ed474d4f7fdf563b5f9e8170e1b63963d81c813747387a5b5cf2da2e264c9bf7d
DIST boto3-1.34.151.gh.tar.gz 846055 BLAKE2B 02074215e95b21078dacc5b6cf0fbe228db90ec75377fc1b6d91731de11b33874a5522fb7f19f7651bc7c1ab479e088ad207c421549f83837ee8cdca0132ca5f SHA512 027c277385f1e12f3dc388755cdc53ce34c0bfc3aef0745a676077fbbb0fb48fa499cfadb574abc3258fe29e39cb0f5d31876c371aed1491c4e6358b11b40fa5
DIST boto3-1.34.152.gh.tar.gz 846770 BLAKE2B a99e3e4fbc374197a3cd3e3c66bc4ea1ef3d4fb6ad649ad30a1268e675f35cb096fd1ce1d28fab33ee179a78cec4ed3216c32ede91a73e7437c625bc99f1ff9f SHA512 f633fcb83598b149038b16fd5a6b46dc0680c3fb9b0a4f6368941e6401739bc958923df40981c40b3525ba703c790964fc50791d4659bae4c1c686864a3e299c
+DIST boto3-1.34.153.gh.tar.gz 847038 BLAKE2B f29aec887fd57d2bc4b6be125787384438e0dba65dd01effcc91016b9301be2fdde315a2fbdc8f122350ae52f904ba1c281aee9a5dc52994ddd11b45ead3f8a3 SHA512 a8d8f75ef48ad8418aafddbdea4fb021f64b041e7beabf68a0c2f6c461c3aa0b3f2f20c33122ac87d57296fd0d14ee8834b96257085c522b556f6aa1d99ea0d1
diff --git a/dev-python/boto3/boto3-1.34.153.ebuild b/dev-python/boto3/boto3-1.34.153.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.153.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}