summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 08:17:59 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-22 08:17:59 +0200
commitf28f09b69ca3e7d25993e33f21f18bb42e382923 (patch)
treeb2c72c72b5f4e4ddb88b2dc1a9f91714bb7bd52c /dev-python/autopage
parentdev-python/httpx: Stabilize 0.21.3 ppc64, #831583 (diff)
downloadgentoo-f28f09b69ca3e7d25993e33f21f18bb42e382923.tar.gz
gentoo-f28f09b69ca3e7d25993e33f21f18bb42e382923.tar.bz2
gentoo-f28f09b69ca3e7d25993e33f21f18bb42e382923.zip
dev-python/autopage: add 0.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/Manifest1
-rw-r--r--dev-python/autopage/autopage-0.5.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/autopage/Manifest b/dev-python/autopage/Manifest
index 8163c311fb1e..2a824204357c 100644
--- a/dev-python/autopage/Manifest
+++ b/dev-python/autopage/Manifest
@@ -1 +1,2 @@
DIST autopage-0.4.0.gh.tar.gz 14809 BLAKE2B 8b91d76c04f3b6519fe2660cbebb50c9b767346b6313303b757b04bea8e7eb8a48aaeaabe364b1b18cadbd5125c95f77b187f779ef83c913e8db13ca88284311 SHA512 a7573dc5d62559f06b54b4b40ffa916209ab7c3348ac7b0cb20ae840fe841e8f8efab1c1853196b4cad0ce5fbc52b679e651f76f7023af960dd8cc876a6d1f14
+DIST autopage-0.5.0.gh.tar.gz 21403 BLAKE2B 1c20123bd7ac9dcfc53d5531ea5cec5dcb2d4b8f4c433ab958b96b769540084989ee841f963d24d1b01c3c4deed9933ab213e3838a898a8fc3261096a272d83d SHA512 b40bf0c432a8ecf82f56cf9679191bf13e5fbf478f1236d197df05e29ac27a1d33bffbf3f66fedbf93548e7314ee1a8f1687fa7c696b35f944f8f5dfd2b2dd19
diff --git a/dev-python/autopage/autopage-0.5.0.ebuild b/dev-python/autopage/autopage-0.5.0.ebuild
new file mode 100644
index 000000000000..48760da42e5b
--- /dev/null
+++ b/dev-python/autopage/autopage-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A library to provide automatic paging for console output"
+HOMEPAGE="
+ https://pypi.org/project/autopage/
+ https://github.com/zaneb/autopage/"
+SRC_URI="
+ https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+python_test() {
+ unset LESS PAGER
+ eunittest
+}