summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-24 04:15:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-24 04:41:06 +0200
commit1993a0bc51671a8f04d18dd45ca3fd55698ef819 (patch)
treeaf7aa07b5f7aa11b305e2a1a9c62469e0c945be9 /dev-python/asyncstdlib
parentdev-python/pyftpdlib: Bump to 1.5.10 (diff)
downloadgentoo-1993a0bc51671a8f04d18dd45ca3fd55698ef819.tar.gz
gentoo-1993a0bc51671a8f04d18dd45ca3fd55698ef819.tar.bz2
gentoo-1993a0bc51671a8f04d18dd45ca3fd55698ef819.zip
dev-python/asyncstdlib: Bump to 3.12.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index 0ea08eb6bbe3..b35edc94b279 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1 +1,2 @@
DIST asyncstdlib-3.12.3.tar.gz 47118 BLAKE2B 83967dc89c0a5fab13ff5f3cebec739644ba16479bf661447c179b491897be0a5933f6ae724f942643d349cef8eaff66cf621c565459b1b8774e93bc51e472ee SHA512 239f0741a694f58e359422bce1e54f6f7e3b1522f10ed4cfd137f4cd8c9861156744d7efa98ab155dd0aa489dbdc452c095d60b77922c6b53177708a65a26d86
+DIST asyncstdlib-3.12.4.tar.gz 47279 BLAKE2B 855f4ebb5619ab4aec429b551fb410855da150916416636737c980712e981a8f3b7339f7691d4fa1ee3439911d6e0733ff2431a520d515b836b183848cfb3013 SHA512 33da70653166525009680cd78e6bb7dabb8518babb73caac26dbea9dbd0b73898d1ffe17755f1505dde1c6a3407c0a31743ea60a66af1b30a587ec39fc4014ff
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild
new file mode 100644
index 000000000000..a2eea4011b68
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}