summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-28 20:06:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-28 20:24:36 +0200
commita2198530e9fa229da2ea7891d3f773317e47a128 (patch)
tree98a1f55af3057bc302e0aa888eebae2b6b103cad /dev-python/astroid
parentdev-python/pylint: Remove old (diff)
downloadgentoo-a2198530e9fa229da2ea7891d3f773317e47a128.tar.gz
gentoo-a2198530e9fa229da2ea7891d3f773317e47a128.tar.bz2
gentoo-a2198530e9fa229da2ea7891d3f773317e47a128.zip
dev-python/astroid: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.15.8-r1.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index d9ffb5932762..a1f8fb9d1d4e 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,2 +1 @@
-DIST astroid-2.15.8.gh.tar.gz 462922 BLAKE2B 6a4bf0a50333701aab9282ab126fc53d30621d4e7a54796ac93d1db30bc37098d5409f3ffe91ed279bce5866e2e381eafc7f54f18c86aa3a7fc835f0bf844d9a SHA512 d5d008df3e99c036fb38094c416c080745dad640d46e837b07336a23d5a929823b8b884564486600335791a1be0568cbe519b76e6bd3334e72725966af8cc5f5
DIST astroid-3.0.1.gh.tar.gz 461593 BLAKE2B de3458bcd9ba111020132e89b6e2fdf18b81b82cba68c986e84af91c910e6c70e7d13ff024b7947f3fa08e2491ba211a77a35421b3d5cd184b94e6a833c0da42 SHA512 2c8a4cf22959aef1eb9510430bcc55d00fcda76d022575786c9a59c093fe4196b67c0b9401f9226595a4cbf1fb9444bdfbb9ac2d83c115ec1d7d46cb7dd75dbd
diff --git a/dev-python/astroid/astroid-2.15.8-r1.ebuild b/dev-python/astroid/astroid-2.15.8-r1.ebuild
deleted file mode 100644
index b99d5fc94b06..000000000000
--- a/dev-python/astroid/astroid-2.15.8-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="
- https://github.com/pylint-dev/astroid/
- https://pypi.org/project/astroid/
-"
-SRC_URI="
- https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# Version specified in pyproject.toml
-RDEPEND="
- >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
- <dev-python/wrapt-2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # no clue why they're broken
- tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
- tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
- tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
- # some problem with warnings (our options?)
- tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
- tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
- tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
- # requires six bundled in urllib3, sigh
- tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
- # requires pip, and looks suspicious anyway
- tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
- # pydantic-2?
- tests/brain/test_dataclasses.py::test_pydantic_field
- # TODO
- tests/test_manager.py::ClearCacheTest::test_clear_cache_clears_other_lru_caches
- )
-
- # Faker causes sys.path_importer_cache keys to be overwritten
- # with PosixPaths
- epytest -p no:faker
-}