summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-13 14:33:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-13 14:49:46 +0100
commitf4b6ddbccf86bd734f4533be7b80e7eaa716a03b (patch)
tree980e2c85c0554ea6a9a6b800fd591641598545d8 /dev-python/argcomplete
parentsys-apps/cpu-x: add 5.0.2 (diff)
downloadgentoo-f4b6ddbccf86bd734f4533be7b80e7eaa716a03b.tar.gz
gentoo-f4b6ddbccf86bd734f4533be7b80e7eaa716a03b.tar.bz2
gentoo-f4b6ddbccf86bd734f4533be7b80e7eaa716a03b.zip
dev-python/argcomplete: Bump to 3.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest1
-rw-r--r--dev-python/argcomplete/argcomplete-3.1.6.ebuild43
-rw-r--r--dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch24
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 041c6f943101..8d055ca8cedf 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,2 +1,3 @@
DIST argcomplete-3.1.2.tar.gz 89541 BLAKE2B ca00006d423244096bc2589b26a06826a4ba5541ab73176425a022a35635df3d575a9d6afe99579d7978e20d6b990f0338af6d4525337b135b27084df6352610 SHA512 661b48548e83e2e7a056f8f1151a81eee72c922951e5d3b7194fa0a08ff77c51eb5043237b9f460e5cb56751d9d159a0b43173b951e5f24094b53fd345cb8e85
DIST argcomplete-3.1.4.tar.gz 79529 BLAKE2B 6b2291ab5d8608de6acf760ec00e3ca7edcf2118a09145eb84faa0805e16fe71165513ce9eec875664191869b279bca0e0a8fae540040a5a6b1c9d178e4272b9 SHA512 d5108273fb570ec42667acefd1cf397e2fbedb3d4fbc31bb2b3206cdbb3275fde88b4d40e9dc65045b6a94334e6b5b9136054c6291edc21dcd0542f1369fe4b1
+DIST argcomplete-3.1.6.tar.gz 79685 BLAKE2B df21d5a68a173a3c09b76d866adf949910ad775eb6c7d09d797308e87c128a6eebe173d89fc95aaa42bb87bf08e9c84aa217e8844c9fab5c680c83e07d0c7854 SHA512 7d625dfc49253281f692254a23e7fc4af155b97a7df55a0b33eba9655281702396a1119269cf80b5650885e00d75886fbdcbd85312e7ccac6d940edd6189d50e
diff --git a/dev-python/argcomplete/argcomplete-3.1.6.ebuild b/dev-python/argcomplete/argcomplete-3.1.6.ebuild
new file mode 100644
index 000000000000..691d9d9b7d84
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}
diff --git a/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
new file mode 100644
index 000000000000..d8348818164d
--- /dev/null
+++ b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
@@ -0,0 +1,24 @@
+diff --git a/test/test.py b/test/test.py
+index c89912a..eedfe36 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -1359,7 +1359,7 @@ class TestBashGlobal(TestBash):
+ if sys.platform == "darwin":
+ # Work around https://stackoverflow.com/questions/24257803
+ command += ' --install-option="--prefix="'
+- install_output = self.sh.run_command(command)
++ install_output = self.sh.run_command(command, timeout=300)
+ self.assertEqual(self.sh.run_command("echo $?"), "0\r\n", install_output)
+ command = "test-module"
+ if package:
+@@ -1395,8 +1395,8 @@ class Shell:
+ def run_command(self, command):
+ try:
+ self.child.sendline(r"echo -n \#\#\#; {0}; echo -n \#\#\#".format(command))
+- self.child.expect_exact("###", timeout=5)
+- self.child.expect_exact("###", timeout=5)
++ self.child.expect_exact("###", timeout=30)
++ self.child.expect_exact("###", timeout=30)
+ return self.child.before
+ finally:
+ # Send Ctrl+C in case we get stuck.