summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-10-26 19:19:27 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-10-28 10:38:42 +0300
commit6163985812c32dfb857483205b8c7afb650ad109 (patch)
tree2873b42cf11a6dba3a283c21c5680a7157dc132d /dev-python/Pyro5/Pyro5-5.15-r1.ebuild
parentwww-apache/modsecurity-crs: add 3.3.5 (diff)
downloadgentoo-6163985812c32dfb857483205b8c7afb650ad109.tar.gz
gentoo-6163985812c32dfb857483205b8c7afb650ad109.tar.bz2
gentoo-6163985812c32dfb857483205b8c7afb650ad109.zip
dev-python/Pyro5: new package, add 5.15-r1
Closes: https://github.com/gentoo/gentoo/pull/33523 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-python/Pyro5/Pyro5-5.15-r1.ebuild')
-rw-r--r--dev-python/Pyro5/Pyro5-5.15-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/Pyro5/Pyro5-5.15-r1.ebuild b/dev-python/Pyro5/Pyro5-5.15-r1.ebuild
new file mode 100644
index 000000000000..4c974b6370a9
--- /dev/null
+++ b/dev-python/Pyro5/Pyro5-5.15-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="
+ https://pyro5.readthedocs.io
+ https://pypi.org/project/Pyro5/
+ https://github.com/irmen/Pyro5
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/serpent-1.40[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-test-on-ipv6.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # https://github.com/irmen/Pyro5/issues/83 (pypy3 specific)
+ tests/test_server.py::TestServerOnce::testRegisterWeak
+)
+
+python_test() {
+ epytest -m 'not network'
+}