summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-24 03:10:07 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-24 05:01:58 -0400
commit997938b5b7bf5deb7943b44a2dc52485d14f8076 (patch)
tree5e1f38f34003c1a74b36b3eca4500d435ffd769c /dev-python/PyQt6
parentdev-texlive/texlive-context: add 2023_p69108-r4 (diff)
downloadgentoo-997938b5b7bf5deb7943b44a2dc52485d14f8076.tar.gz
gentoo-997938b5b7bf5deb7943b44a2dc52485d14f8076.tar.bz2
gentoo-997938b5b7bf5deb7943b44a2dc52485d14f8076.zip
dev-python/PyQt6: restrict to <qtbase-6.8
Attempted to patch it like usually do, but this time around some methods were replaced by alternatives that I'm not sure sip even supports and have no idea how to patch it properly (esp. since hardly know sip and C++ as-is). Issues are in coreand USE=testlib, the rest appears fine. Not much can do other than wait for PyQt6-6.8.0 to release (similarly to what pyside6 does) unless someone else can provide a working patch. If there is a PyQt6 pre-release snapshot will likely use it once available, but these haven't been happening *before* Qt releases lately. Technically no need for a revbump thanks to the binding operator, but, if we do not do it, portage backtracks a lot more and gives confusing messages when the whole Qt stack is involved. So want to propagate the upper bound on user's systems now *long* before the bump (may be wasted if we get a snapshot in time, but that seems unlikely). Will spare stable users given we can just stabilize 6.7.1-r1 to cause a rebuild and odds are we will not stable 6.8.0 either way (may wait for 6.8.1 + PyQt6-6.8.x). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/PyQt6-6.7.0.ebuild2
-rw-r--r--dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild (renamed from dev-python/PyQt6/PyQt6-6.7.1.ebuild)2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.7.0.ebuild b/dev-python/PyQt6/PyQt6-6.7.0.ebuild
index 049def93e827..feeb9ad16db7 100644
--- a/dev-python/PyQt6/PyQt6-6.7.0.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.7.0.ebuild
@@ -47,8 +47,10 @@ REQUIRED_USE="
"
# may use qt private symbols wrt qtbase's :=
+# non-trivially broken with Qt6.8 wrt upper bound, waiting for PyQt6-6.8.0
DEPEND="
>=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ <dev-qt/qtbase-6.8
bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
diff --git a/dev-python/PyQt6/PyQt6-6.7.1.ebuild b/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
index 0788d33ceccf..b4c34d3c8829 100644
--- a/dev-python/PyQt6/PyQt6-6.7.1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
@@ -47,8 +47,10 @@ REQUIRED_USE="
"
# may use qt private symbols wrt qtbase's :=
+# non-trivially broken with Qt6.8 wrt upper bound, waiting for PyQt6-6.8.0
DEPEND="
>=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ <dev-qt/qtbase-6.8
bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]