summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-20 06:02:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-20 06:28:58 +0200
commitcf3fa55caa147576bc77ca0179c89f953767fce0 (patch)
treea1e99856bd495ddbb005670442574b68df72c320 /dev-python/Nuitka
parentdev-python/pyzmq: Bump to 26.0.2 (diff)
downloadgentoo-cf3fa55caa147576bc77ca0179c89f953767fce0.tar.gz
gentoo-cf3fa55caa147576bc77ca0179c89f953767fce0.tar.bz2
gentoo-cf3fa55caa147576bc77ca0179c89f953767fce0.zip
dev-python/Nuitka: Bump to 2.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.1.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 0e4d5b2ae1fc..308932240c82 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-2.1.4.tar.gz 3636629 BLAKE2B b5a3f3067e12029c9bd1e9ae60d1c6c6370d929ad38a8092f0150078440c50ed925768e132ac18542eaa3ab4f2198f6773cb79cf51dee68b3dff9bec26cb37ad SHA512 bd7e164bed8943c5ea3e7ff30069ef7b9308cd47486fded22cf1f2a37274f0f6274b2af0cb84ca188e961745b93ab085f937e228ce193a1fff953537d5143205
DIST Nuitka-2.1.5.tar.gz 3637222 BLAKE2B 1d2b81067cd6877658b4c1665879fe717e10093f635205dd24577ee7039cb20c8151a26378bce639d415987558bc5dc44b0c3e8afa55d202524bff4104b188cd SHA512 ec980c54f7433b87c7e5e3e9d3d6796ec2206c5cb855433146cdeeb64138c2248fa77c2559c1a6e818be9f9977d8bc3b441955c6f63f739b8810ee2d72305a1f
+DIST Nuitka-2.1.6.tar.gz 3637189 BLAKE2B c3ec642ab8b3edfba12133622619082abade48d98bf5c053882fa037fdbe422f22d10f1008179683fc1091b2a7feed7ec406f85485b1f8a216d4e97343296051 SHA512 13eeec833c66a03f4e82c0b5ab543c6622364a99f23b28cfeb63c2658d542ec1007f700de296e67ccc9c40e0217422cf2f14fcf062b72d5d102a9ae5432588f5
diff --git a/dev-python/Nuitka/Nuitka-2.1.6.ebuild b/dev-python/Nuitka/Nuitka-2.1.6.ebuild
new file mode 100644
index 000000000000..123acd66de1f
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}