summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-24 08:25:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-24 11:04:13 +0200
commit90b0b8156055556ce315b29c75729cec9bc1d8d7 (patch)
treebc145eb25ad5ebd8fdadf1aab20533fb301f6347 /dev-python/Faker/Faker-8.1.1.ebuild
parentdev-python/dask: Bump to 2021.4.1 (diff)
downloadgentoo-90b0b8156055556ce315b29c75729cec9bc1d8d7.tar.gz
gentoo-90b0b8156055556ce315b29c75729cec9bc1d8d7.tar.bz2
gentoo-90b0b8156055556ce315b29c75729cec9bc1d8d7.zip
dev-python/Faker: Bump to 8.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker/Faker-8.1.1.ebuild')
-rw-r--r--dev-python/Faker/Faker-8.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-8.1.1.ebuild b/dev-python/Faker/Faker-8.1.1.ebuild
new file mode 100644
index 000000000000..44adab5d87c2
--- /dev/null
+++ b/dev-python/Faker/Faker-8.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest