summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcos Rodrigues Gonzalez <neutroniak@gmail.com>2024-11-27 19:26:58 -0300
committerSam James <sam@gentoo.org>2024-11-28 00:57:29 +0000
commit39be91b48281c28fe1ea8525cc94751fb77c3793 (patch)
tree9c22b4ef2fed99f0be875ffafd846dc0cf26ab59 /dev-php
parentdev-util/cvise: Stabilize 2.11.0 x86, #945151 (diff)
downloadgentoo-39be91b48281c28fe1ea8525cc94751fb77c3793.tar.gz
gentoo-39be91b48281c28fe1ea8525cc94751fb77c3793.tar.bz2
gentoo-39be91b48281c28fe1ea8525cc94751fb77c3793.zip
dev-php/pecl-uuid: add 1.2.1
Signed-off-by: Marcos Rodrigues Gonzalez <neutroniak@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-uuid/Manifest1
-rw-r--r--dev-php/pecl-uuid/pecl-uuid-1.2.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/pecl-uuid/Manifest b/dev-php/pecl-uuid/Manifest
index 1b8bcf0eedf6..61b4e708f762 100644
--- a/dev-php/pecl-uuid/Manifest
+++ b/dev-php/pecl-uuid/Manifest
@@ -1 +1,2 @@
DIST uuid-1.2.0.tgz 16270 BLAKE2B a3746dce1c27973247fd84ccdf8d73809fae775fa0cf133c3bf09c862d93c6c3a53f2d093a1df3dd8bab90f4e58c326e6e7944bfdf436723c79ad5b634e46e18 SHA512 bd557823a8c2b78f74675a2554445eafc69193c6fe5af1f9435cdd90a8efdec0d3974ae8af759fe7d30b2f805876fc2ef55058dea245c9d89a792f634fdb0a10
+DIST uuid-1.2.1.tgz 16903 BLAKE2B bfc0f1a29327a637d4bda687bc00fa588a20aae86ade1e771df64eb2241ef3d5d11e368532ad823bacfc94d57876d0e0ec74703247a3b11282fbd7b70473e8c9 SHA512 32afa4e71e6b3a524b0ab4dcf021b5c6272b4061e4bea352355468f0f001ccba7c1ad72b397c35d012ceabc1a3ade68babe37e3c38ef7d83f6d5c3eee3b528d8
diff --git a/dev-php/pecl-uuid/pecl-uuid-1.2.1.ebuild b/dev-php/pecl-uuid/pecl-uuid-1.2.1.ebuild
new file mode 100644
index 000000000000..dcbc5ea82cc8
--- /dev/null
+++ b/dev-php/pecl-uuid/pecl-uuid-1.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INIT="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS )
+
+USE_PHP="php8-2 php8-3"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="A wrapper around libuuid"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=()