summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-11-18 14:23:23 +0000
committerSam James <sam@gentoo.org>2024-11-25 00:02:06 +0000
commit02f3059f8b50e26695b94dab56ea162f63021fff (patch)
tree855b44b4c5fca988f40ca9f5ea20fefeebe72e4f /dev-php/pecl-yaz
parentdev-php/pecl-stomp: add php 8.3 support (diff)
downloadgentoo-02f3059f8b50e26695b94dab56ea162f63021fff.tar.gz
gentoo-02f3059f8b50e26695b94dab56ea162f63021fff.tar.bz2
gentoo-02f3059f8b50e26695b94dab56ea162f63021fff.zip
dev-php/pecl-yaz: add php 8.3 support
Bug: https://bugs.gentoo.org/943650 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39361 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php/pecl-yaz')
-rw-r--r--dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild b/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..e4d5f45b5344
--- /dev/null
+++ b/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_NAME="yaz"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( README )
+
+USE_PHP="php8-2 php8-3"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~s390 ~sparc ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/yaz-3.0.2:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# Needs network access to z3950.indexdata.com
+PROPERTIES="test_network"
+
+PHP_EXT_ECONF_ARGS="--with-yaz=/usr"