summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 15:28:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:08:08 +0200
commitb509c922d8eb0ee73b941a5a27ab11f51891428f (patch)
tree47526ee3930919ebfea50c88db12adfaae03d929 /dev-php/pecl-ps
parentdev-php/ming-php: add PHP 7.3 support (diff)
downloadgentoo-b509c922d8eb0ee73b941a5a27ab11f51891428f.tar.gz
gentoo-b509c922d8eb0ee73b941a5a27ab11f51891428f.tar.bz2
gentoo-b509c922d8eb0ee73b941a5a27ab11f51891428f.zip
dev-php/pecl-ps: add PHP 7.3 support
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-ps')
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
index e9eca43623d7..ed4909097c9b 100644
--- a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
PHP_EXT_NAME="ps"
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
inherit php-ext-pecl-r3
# Only really build for >=7.0
-USE_PHP="php7-0 php7-1 php7-2"
+USE_PHP="php7-1 php7-2 php7-3"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
@@ -19,15 +19,15 @@ SLOT="7"
IUSE="examples"
DEPEND="
- php_targets_php7-0? ( dev-libs/pslib )
php_targets_php7-1? ( dev-libs/pslib )
php_targets_php7-2? ( dev-libs/pslib )
+ php_targets_php7-3? ( dev-libs/pslib )
"
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ps:0[php_targets_php5-6] )"
PHP_EXT_ECONF_ARGS=""
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
@@ -35,7 +35,7 @@ src_prepare() {
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-pecl-r3_src_install
fi
}