summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-04-12 09:15:59 -0400
committerBrian Evans <grknight@gentoo.org>2022-04-12 09:24:22 -0400
commite1334ba4a790325be74941f734867def8bdcaa72 (patch)
tree4585f23486af5568e56076d0917ee3eb17f15418 /dev-php/pecl-http
parentapp-admin/bitwarden-desktop-bin: remove 1.28.3 (diff)
downloadgentoo-e1334ba4a790325be74941f734867def8bdcaa72.tar.gz
gentoo-e1334ba4a790325be74941f734867def8bdcaa72.tar.bz2
gentoo-e1334ba4a790325be74941f734867def8bdcaa72.zip
dev-php/pecl-http: Add compile options to remove automatic deps
Limits IDNA implementation to net-dns/libidn2 Future customization with USE is possible, but it does not make sense to have multiple IDNA implementations. The code removes duplicate calls even if many libraries are linked. Closes: https://bugs.gentoo.org/837917 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/pecl-http-3.2.5.ebuild4
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.2.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-php/pecl-http/pecl-http-3.2.5.ebuild b/dev-php/pecl-http/pecl-http-3.2.5.ebuild
index 484ce862f8fe..9cadd35fc682 100644
--- a/dev-php/pecl-http/pecl-http-3.2.5.ebuild
+++ b/dev-php/pecl-http/pecl-http-3.2.5.ebuild
@@ -38,7 +38,9 @@ RDEPEND="${DEPEND}
php_targets_php8-0? ( dev-php/pecl-http:8[php_targets_php8-0(-)] )
php_targets_php8-1? ( dev-php/pecl-http:8[php_targets_php8-1(-)] )"
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
+ --without-http-libidn-dir --without-http-libicu-dir
+ --without-http-libidnkit2-dir --without-http-libidnkit-dir )
PATCHES=( "${FILESDIR}/${PN}-3.2.4-curl-cookies.patch" )
diff --git a/dev-php/pecl-http/pecl-http-4.2.2.ebuild b/dev-php/pecl-http/pecl-http-4.2.2.ebuild
index d0642996b9c7..da62a219af9e 100644
--- a/dev-php/pecl-http/pecl-http-4.2.2.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.2.2.ebuild
@@ -36,7 +36,9 @@ DEPEND="
RDEPEND="${DEPEND}
php_targets_php7-4? ( dev-php/pecl-http:7[php_targets_php7-4(-)] )"
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
+ --without-http-libidn-dir --without-http-libicu-dir
+ --without-http-libidnkit2-dir --without-http-libidnkit-dir )
src_prepare() {
if use php_targets_php8-0 || use php_targets_php8-1 ; then