summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-06-29 08:59:56 -0400
committerBrian Evans <grknight@gentoo.org>2022-06-29 08:59:56 -0400
commit6970f393986186a94b83acc34c319039de75c7fc (patch)
tree8085c41a511bd0ee88c037663524a6a46ac075bf /dev-php/pecl-apcu
parentsys-kernel/gentoo-sources: add 5.18.8 and BMQ Scheduler v5.18-r2 (diff)
downloadgentoo-6970f393986186a94b83acc34c319039de75c7fc.tar.gz
gentoo-6970f393986186a94b83acc34c319039de75c7fc.tar.bz2
gentoo-6970f393986186a94b83acc34c319039de75c7fc.zip
dev-php/pecl-apcu: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-apcu')
-rw-r--r--dev-php/pecl-apcu/Manifest2
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild63
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild63
3 files changed, 0 insertions, 128 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index effbc39b4daf..ae62b97debbb 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -1,3 +1 @@
-DIST apcu-5.1.19.tgz 96583 BLAKE2B 330c08a4e557691d0b402111877b3caf56b211256db17cce52a76aeefce7237505eca4ecd71f3770ef3c405182a1604a92cc458cb9bca435b42370fe917e21a7 SHA512 45077e3bd0eac207539e2eafe21968c71f49b8c8920168dbafa87961b041f1d348b6bf1c130104744bc541e1f690854f0a29062e9520db81c04edeee3ef2ed99
-DIST apcu-5.1.20.tgz 96727 BLAKE2B b8223856e0aaa52f90dffa674bbd9b047caa8c91d81b637eafc2f59fbbfdfe0d6ce30e990a87cb4833e895fcfd944f7d57eb6f7356b3e2361d6be5a535bb3a63 SHA512 3e10b7e5dc7481b1250610ef83954875f427b9114d6b232bad9064fc33d8c8906bcc317f94a6cfc9f76c720fa06a44270d259cf2ceef6c1ec9dcadc49254ee1b
DIST apcu-5.1.21.tgz 92516 BLAKE2B 32d73b89bde9ef4eb01c9ad766930e87300b86776c95929607a8aaefba5043e3a7947d064416ac083ff38876fdb41bb03dab1552ac000082e54f809269b4c925 SHA512 a6ffe8349760d27cde0d86017a59a68e9639bf385e606622d807094f4e5fb305bb25b9ce00077d0856f4d223d44329f7a6314c229b62c78d8e2b085593c92bb3
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild
deleted file mode 100644
index c7fb42739132..000000000000
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="apcu"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( NOTICE README.md TECHNOTES.txt )
-
-USE_PHP="php7-2 php7-3 php7-4 php8-0"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="amd64 arm64 x86"
-
-DESCRIPTION="Stripped down version of APC supporting only user cache"
-LICENSE="PHP-3.01"
-SLOT="7"
-
-LOCKS="pthreadmutex pthreadrw spinlock semaphore"
-
-LUSE=""
-for l in ${LOCKS}; do
- LUSE+="lock-${l} "
-done
-
-IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
-
-REQUIRED_USE="^^ ( $LUSE )"
-
-src_prepare() {
- php-ext-source-r3_src_prepare
- # Remove broken tests from php 7.4 due to trivial output differences
- if use php_targets_php7-4 ; then
- php_init_slot_env "php7.4"
- rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
- fi
-}
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-apcu
- $(use_enable mmap apcu-mmap)
- $(use_enable lock-spinlock apcu-spinlocks)
- )
- # Broken upstream autoconf test disables if present at all
- use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- insinto /usr/share/php7/apcu
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of pecl-apcu was"
- elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
-}
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild
deleted file mode 100644
index ab9a31c49a50..000000000000
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="apcu"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( NOTICE README.md TECHNOTES.txt )
-
-USE_PHP="php7-2 php7-3 php7-4 php8-0"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-DESCRIPTION="Stripped down version of APC supporting only user cache"
-LICENSE="PHP-3.01"
-SLOT="7"
-
-LOCKS="pthreadmutex pthreadrw spinlock semaphore"
-
-LUSE=""
-for l in ${LOCKS}; do
- LUSE+="lock-${l} "
-done
-
-IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
-
-REQUIRED_USE="^^ ( $LUSE )"
-
-src_prepare() {
- php-ext-source-r3_src_prepare
- # Remove broken tests from php 7.4 due to trivial output differences
- if use php_targets_php7-4 ; then
- php_init_slot_env "php7.4"
- rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
- fi
-}
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-apcu
- $(use_enable mmap apcu-mmap)
- $(use_enable lock-spinlock apcu-spinlocks)
- )
- # Broken upstream autoconf test disables if present at all
- use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- insinto /usr/share/php7/apcu
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of pecl-apcu was"
- elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
-}