summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-20 21:42:36 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-20 21:52:08 +1300
commitebdb3d76fa3c55b95daf0d73cb655db814b2e8f4 (patch)
tree35ed8ae332af46d6c6fc6703dc47c487f55d3ac1 /dev-perl
parentdev-perl/Video-Info: EAPI6 + tests (diff)
downloadgentoo-ebdb3d76fa3c55b95daf0d73cb655db814b2e8f4.tar.gz
gentoo-ebdb3d76fa3c55b95daf0d73cb655db814b2e8f4.tar.bz2
gentoo-ebdb3d76fa3c55b95daf0d73cb655db814b2e8f4.zip
dev-perl/Video-Frequencies: EAPI6 + tests
- EAPI6ify - Add basic compile tests Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild b/dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild
new file mode 100644
index 000000000000..cc38e57aceac
--- /dev/null
+++ b/dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module
+
+DESCRIPTION="Video Frequencies perl module, for use with ivtv-ptune"
+HOMEPAGE="http://ivtv.sourceforge.net"
+SRC_URI="mirror://sourceforge/ivtv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_test() {
+ ebegin "Compile testing Video::Frequencies ${PV}"
+ perl -Mblib="${S}" -M"Video::Frequencies ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Video::Frequencies ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}