summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-21 23:00:01 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-21 23:00:34 +1300
commitd8524e027af4415f22c4526c81b2438df04530ec (patch)
tree78e44f6fc829a0f641171083bc18c1a626dbc09a /dev-perl
parentnet-irc/hexchat: python2 is no longer supported. (diff)
downloadgentoo-d8524e027af4415f22c4526c81b2438df04530ec.tar.gz
gentoo-d8524e027af4415f22c4526c81b2438df04530ec.tar.bz2
gentoo-d8524e027af4415f22c4526c81b2438df04530ec.zip
dev-perl/Wx-Perl-ProcessStream: EAPI6 + tests
- EAPI6ify - Enable tests (w/ virtualx) - Stop using deprecated wxwidgets.eclass API Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Wx-Perl-ProcessStream/Wx-Perl-ProcessStream-0.320.0-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Wx-Perl-ProcessStream/Wx-Perl-ProcessStream-0.320.0-r3.ebuild b/dev-perl/Wx-Perl-ProcessStream/Wx-Perl-ProcessStream-0.320.0-r3.ebuild
new file mode 100644
index 000000000000..3f0d0bf9c504
--- /dev/null
+++ b/dev-perl/Wx-Perl-ProcessStream/Wx-Perl-ProcessStream-0.320.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+DIST_AUTHOR=MDOOTSON
+DIST_VERSION=0.32
+inherit wxwidgets perl-module virtualx
+
+DESCRIPTION="access IO of external processes via events"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=dev-perl/Wx-0.97.01"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ setup-wxwidgets
+ perl-module_src_prepare
+}
+
+src_test() {
+ virtx perl-module_src_test
+}