summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-15 07:27:23 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-15 08:06:05 +1200
commitd3f2db8d6c8a5aab47ac7a3e79ee3913c89365e6 (patch)
treebbf0b222adc779e9b21d2266a53e11498bbc66e1 /dev-perl/Exception-System
parentsys-auth/sssd: Require USE="ssh sudo" for tests (diff)
downloadgentoo-d3f2db8d6c8a5aab47ac7a3e79ee3913c89365e6.tar.gz
gentoo-d3f2db8d6c8a5aab47ac7a3e79ee3913c89365e6.tar.bz2
gentoo-d3f2db8d6c8a5aab47ac7a3e79ee3913c89365e6.zip
dev-perl/Exception-System: -r bump for EAPI7 + fixes
- EAPI7 - Add USE="examples" - Unconditionally remove bad tests Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Exception-System')
-rw-r--r--dev-perl/Exception-System/Exception-System-0.110.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Exception-System/Exception-System-0.110.0-r2.ebuild b/dev-perl/Exception-System/Exception-System-0.110.0-r2.ebuild
new file mode 100644
index 000000000000..61493e0f475b
--- /dev/null
+++ b/dev-perl/Exception-System/Exception-System-0.110.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DEXTER
+DIST_VERSION=0.11
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Exception class for system or library calls"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Exception-Base-0.22.01
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Unit-Lite-0.100.0
+ )
+"
+PERL_RM_FILES=(
+ "t/pod_coverage.t"
+ "t/pod.t"
+)