summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-13 04:35:12 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-13 04:36:33 +1300
commitfadfada3b0e0ad7d3b84a3837cbd24c831af2ef4 (patch)
tree92d5fd2f7bae4478ae5395c6da0eb8611903275f /dev-perl/DateTime-Format-Mail/DateTime-Format-Mail-0.403.0.ebuild
parentdev-perl/DateTime-TimeZone: Fix wrongly normalised version (diff)
downloadgentoo-fadfada3b0e0ad7d3b84a3837cbd24c831af2ef4.tar.gz
gentoo-fadfada3b0e0ad7d3b84a3837cbd24c831af2ef4.tar.bz2
gentoo-fadfada3b0e0ad7d3b84a3837cbd24c831af2ef4.zip
dev-perl/DateTime-Format-Mail: Bump to 0.403.0
- EAPI6 - Parallel Testing Upstream: - Use ->set_locale instead of ->set to set the locale in order to avoid unintentionally changing local time. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/DateTime-Format-Mail/DateTime-Format-Mail-0.403.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Mail/DateTime-Format-Mail-0.403.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Mail/DateTime-Format-Mail-0.403.0.ebuild b/dev-perl/DateTime-Format-Mail/DateTime-Format-Mail-0.403.0.ebuild
new file mode 100644
index 000000000000..fac53e80c856
--- /dev/null
+++ b/dev-perl/DateTime-Format-Mail/DateTime-Format-Mail-0.403.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=BOOK
+DIST_VERSION=0.403
+inherit perl-module
+
+DESCRIPTION="Convert between DateTime and RFC2822/822 formats"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-1.40.0
+ dev-perl/Params-Validate
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/release-*.t
+ perl-module_src_test
+}