summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-23 19:57:20 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-23 19:57:20 +1200
commite36345ed8195b4bc1cbacbebe8cf365cdcdf7b0f (patch)
tree98cc477c22d38184cb7ef833df01b77b54c6265b /dev-perl/Class-Std/Class-Std-0.13.0.ebuild
parentdev-perl/Class-Method-Modifiers: Bump to version 2.210.0 (diff)
downloadgentoo-e36345ed8195b4bc1cbacbebe8cf365cdcdf7b0f.tar.gz
gentoo-e36345ed8195b4bc1cbacbebe8cf365cdcdf7b0f.tar.bz2
gentoo-e36345ed8195b4bc1cbacbebe8cf365cdcdf7b0f.zip
dev-perl/Class-Std: Bump to version 0.13.0
- EAPI6 - Add USE="examples" Upstream: - Pod Fixed ( Patch upstreamed ) - Class::Std::SCR::VERSION defined Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Class-Std/Class-Std-0.13.0.ebuild')
-rw-r--r--dev-perl/Class-Std/Class-Std-0.13.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Class-Std/Class-Std-0.13.0.ebuild b/dev-perl/Class-Std/Class-Std-0.13.0.ebuild
new file mode 100644
index 000000000000..f1518ab005d6
--- /dev/null
+++ b/dev-perl/Class-Std/Class-Std-0.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=CHORNY
+DIST_VERSION=0.013
+DIST_EXAMPLES=("demo/*")
+inherit perl-module
+
+DESCRIPTION='Support for creating standard "inside-out" classes'
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"