summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/CPAN-Checksums
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/CPAN-Checksums')
-rw-r--r--dev-perl/CPAN-Checksums/CPAN-Checksums-2.80.0-r1.ebuild34
-rw-r--r--dev-perl/CPAN-Checksums/Manifest1
-rw-r--r--dev-perl/CPAN-Checksums/metadata.xml9
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/CPAN-Checksums/CPAN-Checksums-2.80.0-r1.ebuild b/dev-perl/CPAN-Checksums/CPAN-Checksums-2.80.0-r1.ebuild
new file mode 100644
index 000000000000..cca8ecdf412c
--- /dev/null
+++ b/dev-perl/CPAN-Checksums/CPAN-Checksums-2.80.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ANDK
+MODULE_VERSION=2.08
+inherit perl-module
+
+DESCRIPTION="Write a CHECKSUMS file for a directory as on CPAN"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-IO-Compress
+ dev-perl/Compress-Bzip2
+ dev-perl/Data-Compare
+ virtual/perl-Digest-SHA
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"
+
+src_test() {
+ # online test
+ mv "${S}"/t/00signature.t{,.disable} || die
+ perl-module_src_test
+}
diff --git a/dev-perl/CPAN-Checksums/Manifest b/dev-perl/CPAN-Checksums/Manifest
new file mode 100644
index 000000000000..c754ded6ad00
--- /dev/null
+++ b/dev-perl/CPAN-Checksums/Manifest
@@ -0,0 +1 @@
+DIST CPAN-Checksums-2.08.tar.gz 12699 SHA256 b5eae5689056ac48f6c4ea068bc52dfc32c806dae421ddde54ef73dc0cb8215e SHA512 4da547d37b2ca919d7459607bb780b93d78429de88fe0749e23a2e8930ae97cbbd0350e0951fa0facf10ec595bac2bc25ef8da487f81f4e736cc3bd2c0e47f4d WHIRLPOOL 6c70eddef9175445b9abcd7815b3f4b1a3d21edd383cb21ed557531840c6b518d33ee1a5d0e0808a20b43da5eb07fec9b045b57ae5dd8088736c9a1c9f70cae8
diff --git a/dev-perl/CPAN-Checksums/metadata.xml b/dev-perl/CPAN-Checksums/metadata.xml
new file mode 100644
index 000000000000..a3b70dfa4610
--- /dev/null
+++ b/dev-perl/CPAN-Checksums/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">CPAN-Checksums</remote-id>
+ <remote-id type="cpan-module">CPAN::Checksums</remote-id>
+ </upstream>
+</pkgmetadata>