summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-12-05 22:15:09 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-12-19 14:24:22 +0100
commit1407a1a097ebcceffa102d2d5232a6a8e994f182 (patch)
treed9a1da983cc5f5071b11c442f17b9aefdf800717 /dev-perl/CGI
parentperl-module.eclass: Make some former warnings fatal to get rid of PERLQAFATAL... (diff)
downloadgentoo-1407a1a097ebcceffa102d2d5232a6a8e994f182.tar.gz
gentoo-1407a1a097ebcceffa102d2d5232a6a8e994f182.tar.bz2
gentoo-1407a1a097ebcceffa102d2d5232a6a8e994f182.zip
dev-perl/CGI: Add EAPI=6 test ebuild
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-perl/CGI')
-rw-r--r--dev-perl/CGI/CGI-4.220.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-4.220.0-r1.ebuild b/dev-perl/CGI/CGI-4.220.0-r1.ebuild
new file mode 100644
index 000000000000..9d2500eac0ae
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.220.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=4.22
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ virtual/perl-File-Temp
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Warn
+ )
+"