summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-09 11:05:59 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-09 11:11:29 +0200
commit3ffcaf87351d7a9e2f07351a16f26698e0dfa3af (patch)
tree4fa9e20308e0d5dd33e437e4616a48750472d869 /dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.240.0-r1.ebuild
parentdev-perl/Benchmark-Timer: EAPI=8 bump (diff)
downloadgentoo-3ffcaf87351d7a9e2f07351a16f26698e0dfa3af.tar.gz
gentoo-3ffcaf87351d7a9e2f07351a16f26698e0dfa3af.tar.bz2
gentoo-3ffcaf87351d7a9e2f07351a16f26698e0dfa3af.zip
dev-perl/B-Hooks-EndOfScope: EAPI=8 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.240.0-r1.ebuild')
-rw-r--r--dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.240.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.240.0-r1.ebuild b/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.240.0-r1.ebuild
new file mode 100644
index 000000000000..c3c5ddc1e810
--- /dev/null
+++ b/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.240.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION="Execute code after a scope finished compilation"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-perl/Module-Implementation-0.50.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Sub-Exporter-Progressive-0.1.6
+ >=dev-perl/Variable-Magic-0.480.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Text-ParseWords
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"