summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-18 08:04:38 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-18 08:06:59 +0200
commit9c5c318cde6d3b023eac2e20b9edc8a231f97b6c (patch)
treedab487e5db430df7c452d04f1248e666f4139380 /dev-ml
parentdev-ruby/elastic-transport: drop 8.2.2, 8.2.3 (diff)
downloadgentoo-9c5c318cde6d3b023eac2e20b9edc8a231f97b6c.tar.gz
gentoo-9c5c318cde6d3b023eac2e20b9edc8a231f97b6c.tar.bz2
gentoo-9c5c318cde6d3b023eac2e20b9edc8a231f97b6c.zip
dev-ml/opam: add 2.1.6
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/opam-2.1.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index d1d1ef4c062e..c1dc54712bf2 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -4,3 +4,4 @@ DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c67
DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
DIST opam-2.1.3.tar.gz 832450 BLAKE2B c5e50c0a41b7197bc7645eaef0d8cba79c978b4432fc824aa6a4280df65ec7d59df52a22b76877da4949c8562a5fecb8da2a179ca67bd312bf9a514961bf4444 SHA512 040e4f58f93e962ff422617ce0d35ed45dd86921a9aac3505914c33dd942d0e5e5771e7e1774046504f9aa84f32bc4fbd6ac7720fbea862d48bf1ca29e02cefc
DIST opam-2.1.5.tar.gz 837005 BLAKE2B f2e58784959f0e47fbe5ae65112a030d8350b061d7b0d2676f40e22ec5bf62c136bc37fd3078403dab807705ce8a1c8b6bb0ecf00b68fdfbb5f3d5a9acb88c77 SHA512 4395defe7df1d03ca889718b8eafd8161ff009710475f62673f19f012e0bde8ad2a919bd9d02d7f96b4c5a9bbf38e0ba9a256531c24de15cafabd4ef11f7c8e8
+DIST opam-2.1.6.tar.gz 837526 BLAKE2B 1ee60691f4fcc1011f461505942f00ff5f5cc0f0bbfc97edb8e4c676d1e4cd28fed8b49ef341af51a750848be3110713cc97e93a9e63999e4b92e7c7f68d743e SHA512 f75d81b4eb19ef6603e7a2a18e1a281ea6f5eea47b820ae888593102db5b98ded5b593b176e70235611b63a07f4a406a57fe016386f4e921f51b55eb62b9864d
diff --git a/dev-ml/opam/opam-2.1.6.ebuild b/dev-ml/opam/opam-2.1.6.ebuild
new file mode 100644
index 000000000000..fa7540b2dd30
--- /dev/null
+++ b/dev-ml/opam/opam-2.1.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME="opam opam-core opam-format"
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" #see bugs 838658
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/cudf:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+ dev-ml/extlib:=[ocamlopt?]
+ >=dev-ml/mccs-1.1.17:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ !dev-ml/opam-client
+ !dev-ml/opam-core
+ dev-ml/opam-file-format:=[ocamlopt?]
+ !dev-ml/opam-format
+ !dev-ml/opam-state
+ !dev-ml/opam-solver
+ !dev-ml/opam-repository
+ dev-ml/re:=[ocamlopt?]
+ sys-apps/bubblewrap
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo"
+
+src_prepare() {
+ default
+
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}
+
+src_compile() {
+ dune-compile opam-solver opam-repository opam-state opam-client ${DUNE_PKG_NAME}
+}