summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-13 13:50:58 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-13 13:51:13 +0200
commit8890c71ea3daeccd183ea4ae61b07323a5623c08 (patch)
tree2b91c80260f267131bc2b2a73b9caf13a40b797c /dev-ml/yojson/yojson-2.2.2.ebuild
parentwww-servers/tomcat: add 10.1.26 (diff)
downloadgentoo-8890c71ea3daeccd183ea4ae61b07323a5623c08.tar.gz
gentoo-8890c71ea3daeccd183ea4ae61b07323a5623c08.tar.bz2
gentoo-8890c71ea3daeccd183ea4ae61b07323a5623c08.zip
dev-ml/yojson: add 2.2.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/yojson/yojson-2.2.2.ebuild')
-rw-r--r--dev-ml/yojson/yojson-2.2.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-2.2.2.ebuild b/dev-ml/yojson/yojson-2.2.2.ebuild
new file mode 100644
index 000000000000..e987fb1738dd
--- /dev/null
+++ b/dev-ml/yojson/yojson-2.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/sedlex:=[ocamlopt?]
+ !!<dev-ml/seq-0.3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-ml/alcotest )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.1.1-dune-seq.patch" )
+
+src_prepare() {
+ default
+ # let's not build this
+ rm bench/dune yojson-bench.opam || die
+}
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}