summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-02 09:07:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-02 09:22:13 +0200
commita9d5911b4e3eebc02aa7199acba53f2237bfc403 (patch)
treebea035ed1fb9f241b71c61e73da99b35b10960f6 /dev-ml/sexp_pretty
parentdev-ml/core: add 0.16.1 (diff)
downloadgentoo-a9d5911b4e3eebc02aa7199acba53f2237bfc403.tar.gz
gentoo-a9d5911b4e3eebc02aa7199acba53f2237bfc403.tar.bz2
gentoo-a9d5911b4e3eebc02aa7199acba53f2237bfc403.zip
dev-ml/sexp_pretty: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/sexp_pretty')
-rw-r--r--dev-ml/sexp_pretty/Manifest1
-rw-r--r--dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/sexp_pretty/Manifest b/dev-ml/sexp_pretty/Manifest
index 2f426c485ada..ab0927b8d7e3 100644
--- a/dev-ml/sexp_pretty/Manifest
+++ b/dev-ml/sexp_pretty/Manifest
@@ -1,2 +1,3 @@
DIST sexp_pretty-0.15.0.tar.gz 22407 BLAKE2B df8d246ebe1164f0d2d3ae78074c8249d2aa255a089e02eb9fcc0c21b808dc172da2da264d3b21b92dcc7bf9e51a2921ea8631eb45b45a46035447ead7abe02d SHA512 bc2a7aecfc3ae379a56e8940b9cc80ece686009c9f67233e7993e25ebbe251d62559601923db718a0f967cf42fc84024597c069659842760bb2ac5ce0eab8df2
DIST sexp_pretty-0.15.1.tar.gz 22410 BLAKE2B e3819bce21afb8addcf391aff7a330db7f332c338d11f87cf0264d0e8d45ead7897b881a646a908e6165e2b60b9d49c6f2cb4da26ef7f3402ddbc864ff6b088b SHA512 900accca43727f8e7603f21adb0b2bc5a121b1444112b152ed1bfd6ace553b3cd4b2f80371a8f924b636ea33cfa26e913bdcd0ab42e5af5fd24f21ecbca8e736
+DIST sexp_pretty-0.16.0.tar.gz 22557 BLAKE2B e44dbaaf18ffe8899ae636271110cccfeeb61e0284b321ee0d9865e0a8805df4a50540b526988c7f8f0d42092a036421b1e53122c6d22fb38d7ad4295c1055c8 SHA512 531c71dc77abfe9d088eb6213ae9d6563d9a6e1db58a710974120ece6465e192aab4ede6e36e12b6a386bbcfcfa497d5f7a5ac250ea54bdf641cbd597ffc96b6
diff --git a/dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild b/dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild
new file mode 100644
index 000000000000..76bb6484838f
--- /dev/null
+++ b/dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="S-expression pretty-printer"
+HOMEPAGE="https://github.com/janestreet/sexp_pretty"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/ppxlib:=
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/ppx_enumerate:=
+ dev-ml/ppx_hash:=
+ dev-ml/re:=
+ dev-ml/sexplib:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""