summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:55:37 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:44 +1100
commitfdc3d402e25a27842ec686b67d15ae9d24d63c43 (patch)
tree1879ec50a0c4adf7615d0f6172cbd4a42e12e583 /dev-ml/react/react-1.2.1-r1.ebuild
parentdev-ml/re: Dependency of dev-ml/cinaps (diff)
downloadgentoo-fdc3d402e25a27842ec686b67d15ae9d24d63c43.tar.gz
gentoo-fdc3d402e25a27842ec686b67d15ae9d24d63c43.tar.bz2
gentoo-fdc3d402e25a27842ec686b67d15ae9d24d63c43.zip
dev-ml/react: EAPI=7, add ~arm64 from ml-overlay
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/react/react-1.2.1-r1.ebuild')
-rw-r--r--dev-ml/react/react-1.2.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/react/react-1.2.1-r1.ebuild b/dev-ml/react/react-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..961c0c0dde43
--- /dev/null
+++ b/dev-ml/react/react-1.2.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react https://github.com/dbuenzli/react"
+SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ >=dev-ml/topkg-0.9
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test 'true' 'false') \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}