summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-26 18:44:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-27 13:40:36 +0100
commit254a81d6351269615b3494962c15a3509b1c711f (patch)
tree954d53dfc9a87a31c38ffc97ce143779e47ca997 /dev-ml/ocamlbuild/ocamlbuild-0.10.1.ebuild
parentvirtual/perl-Filter-Simple: Spread missing keywords from dev-lang/perl (diff)
downloadgentoo-254a81d6351269615b3494962c15a3509b1c711f.tar.gz
gentoo-254a81d6351269615b3494962c15a3509b1c711f.tar.bz2
gentoo-254a81d6351269615b3494962c15a3509b1c711f.zip
dev-ml/ocamlbuild: bump to 0.10.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocamlbuild/ocamlbuild-0.10.1.ebuild')
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.10.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.10.1.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.10.1.ebuild
new file mode 100644
index 000000000000..c18f0d636628
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.10.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-ml/findlib-1.6.1-r1
+"
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}