summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-27 19:39:43 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-27 19:39:43 +0200
commit6c6e6e1fedd68c9af56e96b9a029ced56fccdfb6 (patch)
tree57bd5e96029f5a56ae40688464b0e9de1fad5546 /dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild
parentpackage.mask: add async_rpc_kernel to janestreet mask (diff)
downloadgentoo-6c6e6e1fedd68c9af56e96b9a029ced56fccdfb6.tar.gz
gentoo-6c6e6e1fedd68c9af56e96b9a029ced56fccdfb6.tar.bz2
gentoo-6c6e6e1fedd68c9af56e96b9a029ced56fccdfb6.zip
dev-ml/async_rpc_kernel: 0.15.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild')
-rw-r--r--dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild b/dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild
new file mode 100644
index 000000000000..7e000a1b3ae6
--- /dev/null
+++ b/dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Platform-independent core of Async RPC library"
+HOMEPAGE="https://github.com/janestreet/async_rpc_kernel"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/async_kernel:${SLOT}
+ dev-ml/protocol_version_header:${SLOT}
+"
+DEPEND="${RDEPEND}"