summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-16 18:21:50 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-16 18:28:42 +0100
commit8d90f3716deb108901cc727f02137478999caf8e (patch)
tree6bd3a459749dc9b3c0d08dfb79feeec2dad1b44f /dev-lua/lualdap
parentdev-lua/lualdap: add lua5-4 support (diff)
downloadgentoo-8d90f3716deb108901cc727f02137478999caf8e.tar.gz
gentoo-8d90f3716deb108901cc727f02137478999caf8e.tar.bz2
gentoo-8d90f3716deb108901cc727f02137478999caf8e.zip
dev-lua/lualdap: drop old version
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lualdap')
-rw-r--r--dev-lua/lualdap/lualdap-1.2.5-r100.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild b/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild
deleted file mode 100644
index af582b86b150..000000000000
--- a/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A lua binding for the OpenLDAP client libraries"
-HOMEPAGE="https://github.com/lualdap/lualdap"
-SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="
- net-nds/openldap
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-HTML_DOCS=( "doc/us/." )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LBER_LIBDIR=/usr/$(get_libdir)"
- "LDAP_LIBDIR=/usr/$(get_libdir)"
- "LUA_INCDIR=$(lua_get_include_dir)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
- LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- # Workaround, as 'make install' does not create this directory
- dodir "$(lua_get_cmod_dir)"
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "INST_LIBDIR=$(lua_get_cmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}