summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaymond Wong <infiwang@pm.me>2022-04-27 23:14:13 +0800
committerJakov Smolić <jsmolic@gentoo.org>2022-04-27 17:54:08 +0200
commit62419f9179e0d69dc513ac4e02e62e10ff3b98cd (patch)
treebddedac66bdb58afa02a1e1b73a5b3332280cc64 /dev-lisp
parentmail-client/mutt: cleanup vulnerable versions (diff)
downloadgentoo-62419f9179e0d69dc513ac4e02e62e10ff3b98cd.tar.gz
gentoo-62419f9179e0d69dc513ac4e02e62e10ff3b98cd.tar.bz2
gentoo-62419f9179e0d69dc513ac4e02e62e10ff3b98cd.zip
dev-lisp/asdf: Fix "test-utilities.script" test
Patch is already done upstream, drop on next version bump. Closes: https://bugs.gentoo.org/841335 Signed-off-by: Raymond Wong <infiwang@pm.me> Closes: https://github.com/gentoo/gentoo/pull/25226 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/asdf/asdf-3.3.5.ebuild5
-rw-r--r--dev-lisp/asdf/files/asdf-3.3.5-test-utilities.patch27
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-lisp/asdf/asdf-3.3.5.ebuild b/dev-lisp/asdf/asdf-3.3.5.ebuild
index b1153ce7066e..f33fc8a4e2a2 100644
--- a/dev-lisp/asdf/asdf-3.3.5.ebuild
+++ b/dev-lisp/asdf/asdf-3.3.5.ebuild
@@ -22,6 +22,11 @@ DEPEND="!dev-lisp/cl-${PN}
PDEPEND="virtual/commonlisp
~dev-lisp/uiop-${PV}"
+PATCHES=(
+ # bug 841335, drop on next version bump
+ "${FILESDIR}"/${PN}-3.3.5-test-utilities.patch
+)
+
install_docs() {
(
cd doc || die
diff --git a/dev-lisp/asdf/files/asdf-3.3.5-test-utilities.patch b/dev-lisp/asdf/files/asdf-3.3.5-test-utilities.patch
new file mode 100644
index 000000000000..d8529d16823d
--- /dev/null
+++ b/dev-lisp/asdf/files/asdf-3.3.5-test-utilities.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/841335
+Taken from https://github.com/roswell/asdf/commit/fd289d99d1c76601fb310f8ca26a48f807337c8d
+
+From fd289d99d1c76601fb310f8ca26a48f807337c8d Mon Sep 17 00:00:00 2001
+From: "Robert P. Goldman" <rpgoldman@sift.net>
+Date: Fri, 2 Jul 2021 15:57:34 -0500
+Subject: [PATCH] Fix garbled test.
+
+By accident a bad test slipped into a commit: this was due to my not
+understanding how `with-expected-failure` works.
+---
+ test/test-utilities.script | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/test-utilities.script b/test/test-utilities.script
+index 09a03347..b1e00fa5 100644
+--- a/test/test-utilities.script
++++ b/test/test-utilities.script
+@@ -342,7 +342,7 @@
+ ;; (assert (directory-exists-p oddball-pathname))
+ ;; (pathname oddball-namestring)
+ ;; (assert-equal nil (uiop:subdirectories oddball-namestring))
+-(with-expected-failure ("UIOP:SUBDIRECTORIES does not handle non-standard pathnames.")
++(with-expected-failure (#+(or sbcl cmucl) t)
+ (assert-equal nil (uiop:subdirectories "/[foo")))
+
+ (DBG "check to make sure WITH-CURRENT-DIRECTORY checks its parameter for directory pathname")