summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-06 13:00:49 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-06 13:01:05 +0100
commit91b39b002114cfc8d0d4c5d34376d252ca136865 (patch)
treefe5ac0c968981b5fea88419b3e29d8ea0fbb4617 /dev-libs
parentsys-auth/rtkit: Stabilize 0.13-r1 arm64, #753179 (diff)
downloadgentoo-91b39b002114cfc8d0d4c5d34376d252ca136865.tar.gz
gentoo-91b39b002114cfc8d0d4c5d34376d252ca136865.tar.bz2
gentoo-91b39b002114cfc8d0d4c5d34376d252ca136865.zip
dev-libs/icu-le-hb: Fixed build with >=dev-libs/icu-68.1
Closes: https://bugs.gentoo.org/751931 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch58
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild4
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch b/dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch
new file mode 100644
index 000000000000..9aa6958faff9
--- /dev/null
+++ b/dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch
@@ -0,0 +1,58 @@
+From c0a0a85833cdcceb636dbe986f39a43ac40f839f Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 30 Oct 2020 15:04:44 +0100
+Subject: [PATCH] Fix build with icu-68.1
+
+icu-68.1 removed public macro definitions for TRUE and FALSE
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/LEFontInstance.cpp | 2 +-
+ src/LEGlyphStorage.cpp | 2 +-
+ src/LEInsertionList.cpp | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/LEFontInstance.cpp b/src/LEFontInstance.cpp
+index e5595f2..89bc3ed 100644
+--- a/src/LEFontInstance.cpp
++++ b/src/LEFontInstance.cpp
+@@ -79,7 +79,7 @@ void LEFontInstance::mapCharsToGlyphs(const LEUnicode chars[], le_int32 offset,
+
+ LEGlyphID LEFontInstance::mapCharToGlyph(LEUnicode32 ch, const LECharMapper *mapper) const
+ {
+- return mapCharToGlyph(ch, mapper, TRUE);
++ return mapCharToGlyph(ch, mapper, true);
+ }
+
+ LEGlyphID LEFontInstance::mapCharToGlyph(LEUnicode32 ch, const LECharMapper *mapper, le_bool filterZeroWidth) const
+diff --git a/src/LEGlyphStorage.cpp b/src/LEGlyphStorage.cpp
+index bac403a..b537676 100644
+--- a/src/LEGlyphStorage.cpp
++++ b/src/LEGlyphStorage.cpp
+@@ -659,7 +659,7 @@ le_bool LEGlyphStorage::applyInsertion(le_int32 atPosition, le_int32 count, LEGl
+ // just got replaced by the insertion
+ fSrcIndex -= 1;
+
+- return FALSE;
++ return false;
+ }
+
+ U_NAMESPACE_END
+diff --git a/src/LEInsertionList.cpp b/src/LEInsertionList.cpp
+index c64b8a1..3e39952 100644
+--- a/src/LEInsertionList.cpp
++++ b/src/LEInsertionList.cpp
+@@ -86,11 +86,11 @@ le_bool LEInsertionList::applyInsertions(LEInsertionCallback *callback)
+ {
+ for (InsertionRecord *rec = head; rec != NULL; rec = rec->next) {
+ if (callback->applyInsertion(rec->position, rec->count, rec->glyphs)) {
+- return TRUE;
++ return true;
+ }
+ }
+
+- return FALSE;
++ return false;
+ }
+
+ U_NAMESPACE_END
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
index 29001e5eecca..fa6e7b24bd9a 100644
--- a/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
@@ -27,6 +27,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/${P}-icu68.patch" #751931
+)
+
src_prepare() {
default
eautoreconf