summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-11-28 22:12:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-30 20:17:39 +0100
commit5fbda7885f91438b4eac8c79e537e71b31a81812 (patch)
tree7d6769230a271f5d38804d750a38d3d2c52fe75a /dev-libs
parentapp-admin/syslog-ng: python3_8 (diff)
downloadgentoo-5fbda7885f91438b4eac8c79e537e71b31a81812.tar.gz
gentoo-5fbda7885f91438b4eac8c79e537e71b31a81812.tar.bz2
gentoo-5fbda7885f91438b4eac8c79e537e71b31a81812.zip
dev-libs/libqtxdg: add version 3.4.0
Closes: https://bugs.gentoo.org/701354 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13788 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libqtxdg/Manifest1
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.4.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/Manifest b/dev-libs/libqtxdg/Manifest
index ffdb11581d0e..347faca726f5 100644
--- a/dev-libs/libqtxdg/Manifest
+++ b/dev-libs/libqtxdg/Manifest
@@ -1 +1,2 @@
DIST libqtxdg-3.3.1.tar.xz 66004 BLAKE2B a676f22144ddbf67e02686fc25b381a911e5d0391e2f735c6d85914362433aad20ad0a3740ea7101d26b5b5692d0504c3798489333b1bf9585c3be88f6636beb SHA512 f0fdb95f20ee49becf770455a513178bb3ce63ee460e8bbaac8d40f50ae47a139ff518021c8fc19254bbd777b67bc7f2754302de7e2bb6cdf929bc559a1b51f3
+DIST libqtxdg-3.4.0.tar.xz 73060 BLAKE2B db23fe8bfb6e8b73a76b710f121464e3a8f5b60f1019705bb6a234eb4c0a9a5ad9469ab95eeac8f392ca10a86343f9d0b3040eae4131d1d421800b8054247d6d SHA512 9bd52ae3aa32f8c7de48e562ada1ff2413892c7ac58d5f7a06c0c512a4a6c03e9c5c44930f7781930c9c701894ea38a450a61a3c26afc047c76313ada0a890e6
diff --git a/dev-libs/libqtxdg/libqtxdg-3.4.0.ebuild b/dev-libs/libqtxdg/libqtxdg-3.4.0.ebuild
new file mode 100644
index 000000000000..98438d2a03ea
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-3.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake-utils_src_test
+}