summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-22 10:08:40 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-22 10:14:39 +0100
commit07b5195672f710e700de7dca39519ea1b58d60b6 (patch)
tree0299b0958a0af41ea3e8d710373ecd13d0929653 /dev-libs
parentapp-admin/gnome-abrt: Bump to 1.4.1 (diff)
downloadgentoo-07b5195672f710e700de7dca39519ea1b58d60b6.tar.gz
gentoo-07b5195672f710e700de7dca39519ea1b58d60b6.tar.bz2
gentoo-07b5195672f710e700de7dca39519ea1b58d60b6.zip
dev-libs/libreport: Bump to 2.16.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libreport/Manifest1
-rw-r--r--dev-libs/libreport/libreport-2.16.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 7116c7dea91f..0c523b06126e 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1 +1,2 @@
DIST libreport-2.15.2.tar.gz 1859867 BLAKE2B f890e3cb8b2a23647e4c3fb0caaf984b1b21fd32e066d04f835f8a475e317cbc75287375e0a10a01b91670d04bba1f15b1180065f7029b8d7d1c0a2fb890914b SHA512 c98003325fa70d674177c9f602a7f121815a9675701ee780ad8908ed69862f2c69be65c7483fd3f017ba299dda51ba304f0908c771c9d97cb5bba057e3a9c5dc
+DIST libreport-2.16.0.tar.gz 1901880 BLAKE2B 520ad157de02dbe5fd15b2ffcfc9b0a09587c3696b41a202f0a78b53a2d366a2991906437aa38d7c84407dcd4a788d358b9e320f70c30e602f1b903433288717 SHA512 cbb456bb63b92a255fecb87191160c2e515b4434cbaaa9404fb69f4f78421fe98c4057969f4b6b99e1b52e815d83c483bdbbe606a4bd2e34cf5268769e7bd40f
diff --git a/dev-libs/libreport/libreport-2.16.0.ebuild b/dev-libs/libreport/libreport-2.16.0.ebuild
new file mode 100644
index 000000000000..f8d64e4b1687
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.16.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk +python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ app-arch/libarchive:0=
+ >=dev-libs/glib-2.43.4:2
+ >=dev-libs/satyr-0.38:0=
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/nettle:=
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ $(use_with gtk)
+ $(use_with python python3)
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}