summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-01 23:01:05 +0000
committerSam James <sam@gentoo.org>2021-03-01 23:35:59 +0000
commitf5779182f8a4a46ee073f783c0eea3e7145e2551 (patch)
treecf04b193490c0bb50ffad91a0560a19fc592e3c8 /dev-libs/uthash/uthash-2.3.0.ebuild
parentdev-db/spatialite-tools: bump to 5.0.1 (diff)
downloadgentoo-f5779182f8a4a46ee073f783c0eea3e7145e2551.tar.gz
gentoo-f5779182f8a4a46ee073f783c0eea3e7145e2551.tar.bz2
gentoo-f5779182f8a4a46ee073f783c0eea3e7145e2551.zip
dev-libs/uthash: Version updated to 2.3.0.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/19727 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/uthash/uthash-2.3.0.ebuild')
-rw-r--r--dev-libs/uthash/uthash-2.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/uthash/uthash-2.3.0.ebuild b/dev-libs/uthash/uthash-2.3.0.ebuild
new file mode 100644
index 000000000000..5e4ed934d4cc
--- /dev/null
+++ b/dev-libs/uthash/uthash-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="https://troydhanson.github.io/uthash/index.html"
+SRC_URI="https://github.com/troydhanson/uthash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/perl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-cflags.patch
+)
+
+src_test() {
+ cd tests || die
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ doheader src/*.h
+ dodoc doc/*.txt
+}