summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-03-09 14:14:47 +0100
committerPacho Ramos <pacho@gentoo.org>2019-03-09 14:14:47 +0100
commitc484d29cbc8c69037f0c96824fa1b6207112500d (patch)
tree196c7634b0686b96400cc3b724aab0b4c2ef963e /dev-libs/totem-pl-parser
parentmedia-libs/libchamplain: Drop old (diff)
downloadgentoo-c484d29cbc8c69037f0c96824fa1b6207112500d.tar.gz
gentoo-c484d29cbc8c69037f0c96824fa1b6207112500d.tar.bz2
gentoo-c484d29cbc8c69037f0c96824fa1b6207112500d.zip
dev-libs/totem-pl-parser: Bump to 3.26.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs/totem-pl-parser')
-rw-r--r--dev-libs/totem-pl-parser/Manifest1
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-3.26.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/totem-pl-parser/Manifest b/dev-libs/totem-pl-parser/Manifest
index 2f0258c541ca..9fdb8ac28a94 100644
--- a/dev-libs/totem-pl-parser/Manifest
+++ b/dev-libs/totem-pl-parser/Manifest
@@ -1,2 +1,3 @@
DIST totem-pl-parser-3.10.8.tar.xz 1618992 BLAKE2B ab7dc3010afb9a2112f19991ee74c43436962a66fa233162b2d2c6743e5727762102f6f0bfed2a30750c0d4e3cf0fbfdb7fdab8568b0cb827e49d0f99a938c41 SHA512 1692fe6d183838bdfb9125ae2bf9fbf74762333a7ebb6becc755bfdbfb8d2ea1ae257f42aab7b7a1ab419aee2b35902176a731f26736a62015806d1423adae70
DIST totem-pl-parser-3.26.2.tar.xz 1314032 BLAKE2B 1513223e7cdebf1b16587a8ef899dd0318d0474d3987a346525cb0f77966c87bf858510c6432f204e4ec758467da273c8644fa6976eb0da237b729f507763646 SHA512 b4d05f6c41942d243be411fb58aa557c0402eac56acc4fc213214a59d20df4354c17d5dec4064a5580f88e721411a16953e69e94c2ebe98e1aaf8b0729b8a83d
+DIST totem-pl-parser-3.26.3.tar.xz 1314216 BLAKE2B 24b1c7e111456b454022ba7262a1e1483420dbd97b6ec99c0e2631acbb8057134b51ff991d2619e6bda57da6c133e211f949915b0fd62d497905fcd58738b43d SHA512 f059fd9447627268ce5029ed48551b0a2b6c30ba28c50a360d37808ad63fa8423824eef29c7f4d7a752f24861d4c7a7139f321fa2e19085085446e7ed15130cd
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-3.26.3.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.3.ebuild
new file mode 100644
index 000000000000..fc87ee2a481d
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="https://developer.gnome.org/totem-pl-parser/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0/18"
+IUSE="archive crypt gtk-doc +introspection +quvi test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ quvi? ( >=media-libs/libquvi-0.9.1:0= )
+ archive? ( >=app-arch/libarchive-3:0= )
+ dev-libs/libxml2:2
+ crypt? ( dev-libs/libgcrypt:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ gnome-base/gvfs[http]
+ sys-apps/dbus )
+"
+
+src_prepare() {
+ # Disable tests requiring network access, bug #346127
+ # 3rd test fails on upgrade, not once installed
+ # Leio: I consider network tests important for ensuring full functionality, thus trying with them again */
+ #sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsability.*\):/*\1*/:'\
+ # -i plparse/tests/parser.c || die "sed failed"
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ # uninstalled-tests is abused to switch from loading live FS helper
+ # to in-build-tree helper, check on upgrades this is not having other
+ # consequences, bug #630242
+ local emesonargs=(
+ -Denable-quvi=$(usex quvi yes no)
+ -Denable-libarchive=$(usex archive yes no)
+ -Denable-libgcrypt=$(usex crypt yes no)
+ $(meson_use gtk-doc enable-gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ GVFS_DISABLE_FUSE=1 dbus-run-session meson test -C "${BUILD_DIR}"
+}