summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-28 23:54:51 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-28 23:55:06 +0200
commit7825624a30fc7901a418ce98a0de8ca8b8d7b1e5 (patch)
treecd3a1ab49d199b092ecc7507ac319dbb01d7de78 /dev-libs/totem-pl-parser
parentdev-db/postgresql: stable 9.6.17 for hppa, bug #709708 (diff)
downloadgentoo-7825624a30fc7901a418ce98a0de8ca8b8d7b1e5.tar.gz
gentoo-7825624a30fc7901a418ce98a0de8ca8b8d7b1e5.tar.bz2
gentoo-7825624a30fc7901a418ce98a0de8ca8b8d7b1e5.zip
dev-libs/totem-pl-parser: bump to 3.26.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/totem-pl-parser')
-rw-r--r--dev-libs/totem-pl-parser/Manifest1
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-3.26.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/totem-pl-parser/Manifest b/dev-libs/totem-pl-parser/Manifest
index 8c826dbfdb9c..12799cab2ebd 100644
--- a/dev-libs/totem-pl-parser/Manifest
+++ b/dev-libs/totem-pl-parser/Manifest
@@ -1,2 +1,3 @@
DIST totem-pl-parser-3.26.3.tar.xz 1314216 BLAKE2B 24b1c7e111456b454022ba7262a1e1483420dbd97b6ec99c0e2631acbb8057134b51ff991d2619e6bda57da6c133e211f949915b0fd62d497905fcd58738b43d SHA512 f059fd9447627268ce5029ed48551b0a2b6c30ba28c50a360d37808ad63fa8423824eef29c7f4d7a752f24861d4c7a7139f321fa2e19085085446e7ed15130cd
DIST totem-pl-parser-3.26.4.tar.xz 1314800 BLAKE2B a069a7b7c394ab5686e827804dd13df06c6af7b8e515e0a0f5023919ecbf720eb8d52643e35bfb99ff4474e67332e072a3c832ef91232bb4108f282b0bc84bce SHA512 afb02a7c70f2fda9cda67b9daa8bab5f15e68a4afd983fb865fb29de71fe8f5c8fdf716e714e3835ac1c3476ce188c6147924a840c4ba82f0c05c3d3c23f5173
+DIST totem-pl-parser-3.26.5.tar.xz 1318700 BLAKE2B 18cea2edff1206ed9c77ac07fb018da0c9bc5550599b45e363d745166f4828adba6a2f77b763602af011c0a12e9f1f9765402fbafbe097fb69890ec7a9520825 SHA512 ce110d92f60da328272a8135a57ba60785ea4bca1fde3703a734969e7ba5b382ef19dc3b8930a5641d8f8effabf627f7e9b2727ee94e69e6144e0f085079e14d
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-3.26.5.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.5.ebuild
new file mode 100644
index 000000000000..353b21ee7b05
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="https://developer.gnome.org/totem-pl-parser/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0/18"
+IUSE="archive crypt gtk-doc +introspection +quvi test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ quvi? ( >=media-libs/libquvi-0.9.1:0= )
+ archive? ( >=app-arch/libarchive-3:0= )
+ dev-libs/libxml2:2
+ crypt? ( dev-libs/libgcrypt:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ gnome-base/gvfs[http]
+ sys-apps/dbus )
+"
+
+src_prepare() {
+ # Disable tests requiring network access, bug #346127
+ # 3rd test fails on upgrade, not once installed
+ # Leio: I consider network tests important for ensuring full functionality, thus trying with them again */
+ #sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsability.*\):/*\1*/:'\
+ # -i plparse/tests/parser.c || die "sed failed"
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ # uninstalled-tests is abused to switch from loading live FS helper
+ # to in-build-tree helper, check on upgrades this is not having other
+ # consequences, bug #630242
+ local emesonargs=(
+ -Denable-quvi=$(usex quvi yes no)
+ -Denable-libarchive=$(usex archive yes no)
+ -Denable-libgcrypt=$(usex crypt yes no)
+ $(meson_use gtk-doc enable-gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ GVFS_DISABLE_FUSE=1 dbus-run-session meson test -C "${BUILD_DIR}"
+}