summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-01-24 10:33:05 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-24 10:33:05 +0100
commitc5be386b5b75cfe5a546d30c535b3c5c083ec227 (patch)
tree33fec1b01dc3c94dae828ef5e08ca6053dc4c235 /dev-libs/serd
parentdev-libs/serd: dropped obsolete 0.30.16 (diff)
downloadgentoo-c5be386b5b75cfe5a546d30c535b3c5c083ec227.tar.gz
gentoo-c5be386b5b75cfe5a546d30c535b3c5c083ec227.tar.bz2
gentoo-c5be386b5b75cfe5a546d30c535b3c5c083ec227.zip
dev-libs/serd: bump to 0.32.2
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-libs/serd')
-rw-r--r--dev-libs/serd/Manifest1
-rw-r--r--dev-libs/serd/serd-0.32.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/serd/Manifest b/dev-libs/serd/Manifest
index 147e193b5442..788863f8dd66 100644
--- a/dev-libs/serd/Manifest
+++ b/dev-libs/serd/Manifest
@@ -1 +1,2 @@
DIST serd-0.32.0.tar.xz 168028 BLAKE2B 839440f197a7b9b4082c7a39a7f63ddcc9129aed8968ab5a52780d0b8072743c78d7ccd9d6fc0e810944e3f55661cbd11969ea0f0242d4133d1883098ca4215c SHA512 eefd5e4b371213cc77cff3ca6e67c0c460d7cd1a70e55dbac64948ab77703679ee24a446f51d6bfc229fe0cd8089d32eeaa236136cbd1162f7d2100ed2946cbc
+DIST serd-0.32.2.tar.xz 168840 BLAKE2B 5b2ad72ddced2edcb948d75e795c95dccc50ad5be4bf3100c34ead4ec43944647c4f8ff419cda2b7a005b9b69dbd6fa9a0733b2810ad95a9051df3d4253ddfe9 SHA512 052f0765a9af6883a7ef1a31bd90eea3c57d93747dfb989eeda8c4dabbf2ae7d2e868d437aa2a510243f3a535e366739fe266cf82ef0d280472868c87055d50a
diff --git a/dev-libs/serd/serd-0.32.2.ebuild b/dev-libs/serd/serd-0.32.2.ebuild
new file mode 100644
index 000000000000..f612b9721a49
--- /dev/null
+++ b/dev-libs/serd/serd-0.32.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
+HOMEPAGE="https://drobilla.net/software/serd.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc test +tools"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-text/doxygen
+ dev-python/sphinx
+ dev-python/sphinx-lv2-theme
+ dev-python/sphinxygen
+)
+"
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -i "s/versioned_name/'${PF}'/g" doc/man/meson.build doc/html/meson.build doc/singlehtml/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+}