summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/re2/re2-0_p20140304.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/re2/re2-0_p20140304.ebuild')
-rw-r--r--dev-libs/re2/re2-0_p20140304.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/re2/re2-0_p20140304.ebuild b/dev-libs/re2/re2-0_p20140304.ebuild
new file mode 100644
index 000000000000..9496910e814e
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20140304.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils multilib multilib-minimal toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+# Symbols removed in version 20140110
+# http://upstream-tracker.org/compat_reports/re2/20131024_to_20140110/abi_compat_report.html
+# https://code.google.com/p/re2/issues/detail?id=111
+SLOT="0/0.20140110"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+src_configure() {
+ tc-export AR CXX NM
+ append-cxxflags -pthread
+ append-ldflags -pthread
+}
+
+multilib_src_test() {
+ emake static-test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}