summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-02-08 04:11:42 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-02-08 04:11:42 -0500
commit7e18a02010daf6cdad81f433f09e15f835eb3561 (patch)
treefdd833e001d7dcaa0f9f07e68c40a15e6a909933 /dev-libs/mpfr
parentprofiles: force USE=pic on default/linux/x86/17.0/musl (diff)
downloadgentoo-7e18a02010daf6cdad81f433f09e15f835eb3561.tar.gz
gentoo-7e18a02010daf6cdad81f433f09e15f835eb3561.tar.bz2
gentoo-7e18a02010daf6cdad81f433f09e15f835eb3561.zip
dev-libs/mpfr: version bump to 4.0.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/Manifest1
-rw-r--r--dev-libs/mpfr/mpfr-4.0.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/mpfr/Manifest b/dev-libs/mpfr/Manifest
index e889aa6cb7e1..8561fac50415 100644
--- a/dev-libs/mpfr/Manifest
+++ b/dev-libs/mpfr/Manifest
@@ -7,3 +7,4 @@ DIST mpfr-3.1.5-patchset.tar.xz 1840 BLAKE2B c18392ecc3325c0b889b540257f3bfe3c38
DIST mpfr-3.1.5.tar.xz 1126668 BLAKE2B f902925036a4310e7b10461438bae5d5770b95ca6bd897038dc306d597ea412013c869b3d2f9c4ba2a1d5e59eee67f562fc3bf5db8fd1584b70c1b30574e42f5 SHA512 3643469b9099b31e41d6ec9158196cd1c30894030c8864ee5b1b1e91b488bccbf7c263c951b03fe9f4ae6f9d29279e157a7dfed0885467d875f107a3d964f032
DIST mpfr-3.1.6.tar.xz 1133672 BLAKE2B ab8b87be9d29e9ae5807976f72d65e16cd3e5b4c2ffc4e5bd7829e664250b1969a1ec3928b3519cd75365692e23eadfd413a8116f8c77d6cd66183020b72b656 SHA512 746ee74d5026f267f74ab352d850ed30ff627d530aa840c71b24793e44875f8503946bd7399905dea2b2dd5744326254d7889337fe94cfe58d03c4066e9d8054
DIST mpfr-4.0.0.tar.xz 1406244 BLAKE2B 2d1e356ac1f7119aa8896c438e7e30c4b316780d76fa2690e50482005e9ff5d6b5cd368d4c9a524df66ea3e7f2942c627329fa15be83402209c6e249cd1abd28 SHA512 9c9c4535f33fffd2126d1c290e5eeda7cd2804219244643f09c9a2d2acfa3d410d2cb1e4a7bb77cd86cffc2fac59c7f5d32c9910317cac37dbca474ab6d63808
+DIST mpfr-4.0.1.tar.xz 1412692 BLAKE2B 3e8d5cf558071571c21417088e74b8cb94a2e179667af41f734a68c7bd89d4beff245b9344c4c37d2f6558036a1a8c9ad3ea5ec8fbde16d2c7ebbf37a22cf424 SHA512 137ad68bc1e33a155edc1247fcdba27f999cf48ed526773136584090ddf2cfdfc9ea79fbf74ea1943b835b4b1ff29b05087114738c6ad3b485848540f30cac4f
diff --git a/dev-libs/mpfr/mpfr-4.0.1.ebuild b/dev-libs/mpfr/mpfr-4.0.1.ebuild
new file mode 100644
index 000000000000..a29d3dff1208
--- /dev/null
+++ b/dev-libs/mpfr/mpfr-4.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
+inherit eutils libtool multilib-minimal
+
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+PLEVEL=${PV/*p}
+DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE="http://www.mpfr.org/"
+SRC_URI="http://www.mpfr.org/mpfr-${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/6" # libmpfr.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.0.0[${MULTILIB_USEDEP},static-libs?]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+HTML_DOCS=( doc/FAQ.html )
+
+src_prepare() {
+ if [[ ${PLEVEL} != ${PV} ]] ; then
+ local i
+ for (( i = 1; i <= PLEVEL; ++i )) ; do
+ epatch "${FILESDIR}"/${MY_PV}/patch$(printf '%02d' ${i})
+ done
+ fi
+ eapply_user
+ find . -type f -exec touch -r configure {} +
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Make sure mpfr doesn't go probing toolchains it shouldn't #476336#19
+ ECONF_SOURCE=${S} \
+ user_redefine_cc=yes \
+ econf \
+ --docdir="\$(datarootdir)/doc/${PF}" \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ rm "${ED}"/usr/share/doc/"${P}"/COPYING*
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libmpfr$(get_libname 4)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libmpfr$(get_libname 4)
+}